Not all notes in chord sounding when in latch mode

So I’ve found this annoying bug to do with latch mode in Scalar2. It’s not working as it should.

MY SET UP: I am using Scalar2 to trigger chords using single notes in a live gig setting. In Logic Pro X (or MainStage) I have Scalar2 as a plugin in MIDI FX channel (to make single fingering chords). I’m using a Kontakt7 organ software instrument. My external 1-octave MIDI foot pedals (controller keyboard) allows me to trigger different chords by pressing only one key with my foot. Basically, I get different chords within a chosen scale. I’ve customised the chords as well and saved them as presets ‘D major’, ‘B minor’ etc etc. This is so I can select a key/mode to get the 8 chords I want, and then trigger those chords with my feet, which frees up my hands to play my main instrument (a flute). Sounds nuts I know, but it works great.

Except…

ISSUE: I have Scalar2 set to ‘latch mode’ so that the chords sustain until I hit the next key on the controller keyboard, but the chords just aren’t sounding properly. There are notes missing from the chords and they sound sparse and weird! If I turn the note off (by hitting the key again), and then hit it back on I’ve noticed that the chords work perfectly. It’s basically not latching correctly.

I discovered that when I switch ‘latch’ mode off in Scalar2 settings menu for a second, and play the chords with no latching, then they seem to work perfectly (all chord notes are sounding correctly), and when I switch latch mode back on again, they are still working correctly - so finally it works fine in latch mode. So basically every time I load up this chord set in Scalar2 I find myself having to go to settings, and switch latch mode on and off for a second, and then it works fine. But that’s a total pain to have to do that every time I start using this setup.

Anyone else experienced this issue?

Is a CPU overload issue? I have shut down all background app/tasks and my MacBook is an M1 with 16GB memory. Activity Monitor says that MainStage is using 24% memory. But it always works perfectly after I’ve done the ‘on/off’ latch mode in settings trick (mentioned above). Makes me think it’s not a memory issue.

What’s going on? :thinking:

Maybe I should use latch mode within main stage instead? Is that possible?

Any help much appreciated. It definitely feels like a bug.

Hi @HamishNapier

I am using Scaler in Ableton Live 11 on Windows and found what I think may be your issue,but I think I may also have an explanation of what is happening.

When playing two chords which share notes such as C maj (C,E,G) and Emin (E,G,B) with Scaler in Legato Latch mode I think the common notes are tied and not retriggered.

I have prepared a short video of this happening, which can be downloaded from here, and the Scaler state and midi output are below.

Someone with more technical knowledge may want to confirm this, but that is what appears to be happening with triads. With extended chords, because fewer notes are common between the chords the second chord may appear to not play the full chord, only those notes that are not common to both chords.

Scaler-MidiCapture-With-Markers.mid (407 Bytes)

Scaler-State_2024-05-13_175117.xml (12.3 KB)

Following on from my reply above I have done some more testing and found an interesting result when testing using Passages.

When switching between chords that have common notes (e.g. from C maj to E min where E and G are common, or from F maj to D min where F and A are common) the common notes are held. However, if the chord is then repeated all the notes in the chord are triggered. Because of this inconsistency in triggering the common notes I am not sure if this is a bug.

Again I have recorded a short video to illustrate this point here