Plugin Boutique Scaler 2.3.1 update Not showing in my account

Checked my account twice now 2.3.1 is not showing on my Plugin Boutique.

Have you tried looking on your email for any update reminder? the Scaler updates should be on “My Updates” so, if it’s not there, you have a problem with the license or the account.

Seems to be a delay for Scaler 1->2 Upgrade users. There’s been a discussion around this already, and here was the suggested workaround…


This worked for me, thank you for the suggestion. :slight_smile:


Yes, trial worked fine. Merci beaucoup Ed.

Yeh i check mail everyday. Plugin boutique shows me when i login if i have updates with scaler or anything else. I have not received an update by mail or in my PB account. Yet i own Scaler and Scaler 2. I get PB emails and offers almost daily. Three days later only 2.3 is in my account and ive had nothing about a Scaler update.

read a few post above and you’ll find the solution
simply download the trial and it will be automatically registered to you

I have just grabbed the demo that says 2.3.1. I normally have no problems with Scaler updates with PB so hopefully this will be sorted out at some stage.

Yeh i did cheers all. :slight_smile:

1 Like

Not sure I want to install a trial version over my licenced copy, is that the only way around this or is there just a delay in getting the update onto Plugin Boutique? that being the case I would rather wait till it appears there.

Hi @keydecisions, I can assure you that @Ed1 's recommended approach for now works just fine. A couple of us have followed that and it worked just fine getting our fully functional Scaler 2 versions up to 2.3.1. The way this works is that most software code installed contains all functionality, and it is the installed license key that enables the functionality to the user. In the case of Scaler, once you have the license installed at your initial purchase, it carries forward. For me, I found this newly discovered method to update my Scaler code actually more convenient. It takes me far fewer clicks to just search for the Scaler 2 page on rather than clicking through My Account etc. Anyway, not to worry, it works just fine, by experience of a couple of us already. I can recommend it wholeheartedly (for those who rather not wait)


You have the license already. Just install the trial (which is the latest) and it will become licensed to you. As already stated, this is a good work around for the 2.3.1 not showing in your account.

When the upgrade wasn’t available I sent an email to PluginBoutique support. That was a few days ago. Finally I got a reply. They pretend that this problem never existed and they write:

“we don’t add the updates and full versions at different times, they are added together so I’m not sure what you mean there.”

Amazing that they do not know, or pretend not to know about this irritating issue!

They don’t know. Really, really :slight_smile: Ecommerce support is a nightmare job.
Could you send them screenshot of your account’s product list that show Scaler without new version?
They have to see to believe :laughing:
I can not do it as I’m the lucky one - had the update available days ago.

I got upset and told them to check things out which they did and all of a sudden they acknowledged the issue! But the support person did not apologize for his inappropriate and rude reply. He should get another job…
Anyway, thanks to Ed’s suggestion of installing the 2.3.1 demo I got it fixed. Was just thinking about thousands and thousands of other users who did not get access to the update!


Woohoo, Houston we have no more problem :slight_smile:


La gatta frettolosa fece i gattini ciechi
Haste makes waste
Ouvrage hâté, ouvrage gâté
La prisa crea desperdicio
Gut Ding will Weile
A pressa não é inimiga da perfeição? (thanks to @Bernd :smile:)

A pressa não é inimiga da perfeição?

1 Like