Possible bug using Scaler 2 in Cubasis 3 on iPad

Hi all

I am using Scaler 2 with Cubasis 3 in a 2021 iPad Pro. There is either a bug or I am doing something wrong. In the video below, I play in a sequence and it sounds fine, but when played back in Cubasis 3, it seems extra and unwanted midi notes are recorded and it sounds terrible!

Any thoughts?

Hi @Bill,

turn perform off after you dragged the midi into Cubasis otherwise the performance will be played twice.

Hope it helps,


Oh of course, thank you Fred :grinning:

Actually I think something is still not quite right. As you will see, Perform was turned off here, but the recorded sound differs from the live input

Hi @Bill,

I recorded a video showing the process from the beginning:


Try to reproduce these steps and let me know.



Yes, I totally understand the method now, thank you. I have been trying to achieve something a little more complex, involving two patterns. Pattern 1 is in perform mode, Pattern 2 is just holding long chords. The Pattern button is greyed out throughout here, yet Pattern 1 still “performs”. Pattern 1 is assigned to Group 1 whilst Pattern 2 is set to Global. I hope you can figure this out from the video!

In this example, the live performance differs from the recorded version, but the Perform icon is greyed out throughout, so I can’t see how I can switch off before playing back the recorded piece.