Problem with midi region after dragging into DAW using Scaler 2 trail and Pro Logic

I’ve been using the Scaler 2 trail with Pro Logic. I’m new to music production in general so its taking me a hard time to pin down a issue I am having. I can create chord progressions in the Scaler 2 trail version I am using and drag it into my Pro Logic DAW and it plays just fine. Whenever I use a voicing from the performance mode, the midi region inside the DAW is jumbled up. It doesn’t play every note or chord and is a big mess. Its like it will play the first chord, misses the next two, plays another one, etc.

I’m hitting the sync button so I’m assuming the bpm is syncing between the DAW and Scaler. Again, it works fine with just a basic chord progression. What could be the problem?

Welcome to the forum @ORourkeKings Sounds like when you are dragging it across you still have the BIND button activated in section A, B or C and doubling the performance. Have you turned off BIND mode after dragging MIDI to your DAW?

I don’t rememeber if I had the keys set to bind mode. Is it done automatically when performance mode is enabled? I will check that and see if its the problem. One more quick thing. IF binding has to be enabled to use the performance/expressions, etc. HOW are you able to use those performances in the DAW just like the basic chord progressions that you can drag into the DAW?

I went back and did a performance WITHOUT the binding and the performance was accurate in my Pro Logic DAW.

Now its going back to the SAME problem. No binding. If I use a progression without a performance, it syncs. If I add a performance, it gets jumbled. This is WITH and WITHOUT daw syncing enabled. I’m about to bounce on this product.

Sounds to me like you are not using Scaler correctly. Are you exporting the MIDI and using that MIDI to drive the same Scaler the MIDI was derived from? This is unclear to me.
Can you please list the steps you are doing and what exactly you are trying to accomplish.
Screen shots might help.

I create a instrument track with scaler as the instrument ( I can hear the felt piano from scaler playing in the daw). I then drag the progression I created into that same scaler instrument track.

Can you take a screen shot? Sounds to me like the MIDI is retriggering the chords which is what you should avoid.

I believe I have found the problem. What I have being doing is I would drag a basic chord progression into the daw to see how it sounds. I would then delete the midi region in the daw, click on performance and drag the performance version into the daw. The daw is reading the original instance and the new instance.

I wasn’t aware that I could keep the original progression in the track, then just click “performance” in scaler and it will change the basic progression into a performance simultaneously in the daw. I have been doubling the midi region like you said. I don’t have daw sync on either and its working like it should. To test my theory, I clicked performance OFF in scaler and the midi region in the daw went back to the basic progression. I clicked performance back on and it went right back to playing performance in the daw. Hopefully this solved this, lol.