Problem with 'Record Midi to Track' Feature in Logic

I’ve had a huge problem with Scaler 2.7 in Logic since I bought both a M1 Mac Pro and Mac Studio Ultra. My Scaler chord patterns go up semi tone when I record them by manually playing chord patterns using the new ‘record to midi track’ feature in Logic. When I play the recorded midi file back however it goes back to the original chord sets.
I was told to use Logic in Rosetta mode but that defeats the whole purpose of the enhanced performance of the M1 chip. Not an option
Would you have any suggestions here? Scaler is an essential composition tool for me. I’d like to be able to use all it’s wonderful features.

Hi @JLP

Version 2.7.2 should improve the stability on M1 systems. You can try to update it and see if it works better.

It seems to work fine now. I havent tried split channels yet though. Thanks for taking the time to respond.

Unfortunately the split part function does not work properly. When I load divisi into a Kontakt multi (on four separate midi channels) it plays the full chord on all channels. It does not split the notes. Is this a known problem?

I don’t think this can be a Scaler issue. Here is a monitor log of output from Divisi ‘Hans’ at the output MIDI port.

It’s clear it sends out the data by channel. I assume that Logic and the recipient Kontact VST can recognise channels.

I feel it’s probably rude to ask ( and I’m embarrassed to do so), but have you checked that multi-voice output hasn’t reverted to ‘off’ by accident ?
mvo

Worthwhile checking the settings on the VST again to make sure the part channel numbers align.

First, thanks for taking the time to reply. I appreciate that.
I wish it was as simple as the ‘multi voice’ not being checked. I would humbly (yet happily) admit my mistake.

Here’s a pic where you can see Multi Voice is checked and. I’m getting midi on all four channels (in the pic on Midi 4) but rather that splitting the notes of the scaler chord, one note of the chord to each channel, it’s playing the entire chord on each of the four midi channels. I can’t figure out why! I was so excited about this feature but like the live sync, it may need an update to work on M1’s.

Hmmm. The first thing I can say is that this is clearly a problem and it is stopping your use of Scaler as intended.

However, what is clear is that the MIDI coming from Scaler is output on separate channels and no notes are duplicated when it is run in other hosts. It follows to find the answer we have to look downstream of Scaler or at the Scaler/ Logic boundary. Now it may be that some quirk of hosting Scaler in logic causes duplication of notes (or more likely they are being seen as MIDI Omni) by the Logic/Scaler interface, and this might still mean that it is somehow a Scaler specific issue if it didn’t happen with anything else.

I suggest trying two things.

{1} Can you put a MIDI monitor after Scaler (as in my example) just to check what Logic is actually receiving. This would confirm that there is in fact a channel number as it goes into Kontact.

{2} Probably the best way - Instead of Scaler sending data to the current target, put the vst on another muted track, then drag and drop the MIDI from Scaler into the track it was previously running in. Check the notes have a channel associated with them If so, use that to drive the Kontact synth.

If it plays as expected, there is an interface / API issue with Scaler and Logic / Kontact…

If it plays all notes again, that rules out Scaler as an issue, and it’s something else in the rest of the chain.

I emphasize that I know squat about Macs ort Logic, but these seem logical diagnostic paths. Maybe a Mac / Logic person might chime in … @jamieh is pretty much the resident expert on matters Apple.