Problems with Scaler 1.5 in Bitwig 2.4

Hi, I bought Scaler 1.5 from pluginboutique. However, it has some scaling issues in Bitwig 2.4 on Windows 10 (Surface Book 2) which your pluginboutique mentioned as an ok program to work with Scaler. Every time I open the Scaler, its window is bigger than the screen with no chance to make it smaller. To the point that a single button on a plugin dashboard occupies half of screen. With no way to resize the window. It is impossible to work with Scaler this way. The official forum of Scaler indicates the scaling issues with VST 3 version of Scaler and allegedly no issues with VST 2 version. Well now, the installer that I downloaded from your pluginboutique, even though indicates installing VST2 and VST3 in reality installs only VST 3 on a computer and does not give you a real chance to install only VST 2. Also, when closing Bitwig, it just crashes and does not react with a notice that some Scaler VST 3 preset is causing troubles and Bitwig cannot save plugin settings. Can you please help with this? Is there a way to install only VST 2 version? How? Or any other solution.

Hi @imad,

thanks for reporting your issues, and sorry about the inconvenience.

  • It is the second time a user has reported scaling issue on Windows. We haven’t been able to replicate this issue on our setups yet, are you aware of any specifics of your setup that could impact this? (screen resolution, dpi, custom interface scaling settings in Windows, etc…)

  • Regarding the installer, VST2 and VST3 are both installed to different locations, it is possible that Bitwig is not configured to look for the correct VST2 folder. On my setup, the default settings weren’t correct but now I can see both VST2 and 3. Make sure the paths are correct in Bitwig > Settings > Locations.
    Scaler installer defaults to:

    • VST3: C:\Program Files (x86)\Common Files\VST3
    • VST2: C:\Program Files (x86)\Steinberg\Vstplugins
  • About the crash when saving the project, it is probably not related to using the VST2 or VST3 and would most likely occur in both versions, unfortunately. We will investigate this.

There is a new version of Scaler (1.6) coming next week, it contains a lot of bug fixes and improvements over the current version. I have sent you a private message with explanation on how to get the beta if you wish to try it.

Hi, man,

Look I have installed version 1.6 but it has not solved the issues which are:

  1. When using track pad on my Surface Book 2 13 and pressing the keys or chords with a mouse, NO SOUND! When using my midi keyboard (Ableton Push 2), it makes sound. It is very strange and inconvenient, because for me it is easier to use track pad sometimes or a mouse. I have uploaded the screenshots of the problems I encounter.
  2. Not sure if it has been fixed in 1.6 version. But in 1.5 version, the first time you open the plugin window, it is ok sizewise. But when you close it and open again, the window becomes very large and it does not fit within the display ( I use 3000 X 2000 resolution, but it is the same story with just HD) and when I am forced to close the window,
  3. Bitwig indicates some strange message about VST3 preset problem and then becomes unresponsive and I have to forcedly close the DAW through the task manager.

I like your plugin and I hope you will fix it soon, because it is frustrating not being able to use it.

I made screenshots of MIDI output-input setup within Bitwig, just look, maybe I made some mistake with routing.

Thank you and best regards,


Hi imad,

Sorry to intervene. I’m scaler user as well.
I read that Bitwig and some DAWs, don’t play well with VST3 plugins. You could try and delete the VST3 version in C:\Program Files (x86)\Common Files\VST3, and see if the VST2 will work properly.
I use Cubase and installed both the VST2 and VST3 versions, but only the VST3 shows.

I don’t know how Bitwig works, but you may have to re-scan your plugins if you try that suggestion!

Hi, thanks for the additional details

Definitely VST3 issues.
Try to get Bitwig to find the VST2 version and the triggering issue will go away.
For the routing, there are different ways: Setup - Bitwig Studio 2 - External Instrument Control

It seems OK now in the 1.6, just tried it and couldn’t reproduce on Windows 10 - Bitiwig 2.4. Let me know if you experience it again and we will try to figure what is causing this.

I have just noticed the same behavior on Windows 10 running FL Studio in 32bit. The 64bit of FL Studio works correctly.

Which version of Bitwig are you using ?