Query re: ReMidi to Scaler settings

Hi all,
I’m using Logic and having problems with setting Scaler to play the Re-Midi through its scale settings. I can get Re-Midi to play its sounds through scaler, but no matter what key I change Scaler to, it plays exactly what Re-Midi is playing.
I have Keys-Lock turned on and set to ‘Scale Notes Mapped’, but it doesn’t translate into the scale, but just plays what Re-Midi is playing.

Is there an additional Scaler setting that I need to activate in order to alter the Re-Midi notes?
Thanks for any settings suggestions!

Hi Mikeb55
Associating Remidi with Scaler offers many possibilities (more or less random, depending on your configuration), although such configuration is sometimes quite a task to configure. I am sending you these suggestions in case they help you:

First things first: you need to configure what you want Remidi to move. Choose your song on Remidi.
Don’t forget, on the right cogwheel (in Remidi Settings) leave Internal Sound OFF and CHANNELS ON
Send Remidi’s output to Scaler. Depending on your DAW this is done in different ways. I leave here one of my configurations in Ableton.
Observe the key that Remidi offers you in its interface for the chosen song, in terms of key and time signature. You can put another key in Scaler, but if in Remidi it is minor, I suggest that in Scaler you also put minor, for example- As for the time signature, I also recommend: binary in Remidi/binary in DAW and ternary in Remidi/ternary binary in DAW
4º By having the output from Remidi to Scaler configured, when you play something for Remidi to send it, it will also affect what sounds in Scaler. So in my example you’ll notice that Remidi has Midi input turned off and I’ve just written some notes on one track
Use Filter in Remidi to choose which layers you want to send to Scaler
And use your ear and good taste and when you’re happy, you can send the Scaler’s output to other instruments if you like.
Important: Put the same scale (or minor, if it is minor; major if it is major in Scaler, and activate the detection in B
I hope I can help you.
Remidi settings

3 Likes