Reaper crashes

I’ve been experiencing crashes in Reaper while saving after the removal of Scaler from a track or deletion of a track where Scaler is inserted.

Anyone had similar issues?

I’ve already created a post here on this topic but seems to have dissapeared…

I answered on another post, but repeat it here, just in case.
I had a similar issue once. BTW, which version of Reaper are you using? I am in v. 6.2 but this happened on 6.0 if I am not wrong.
I tried with 3 tracks. Remove one, saved, no problem. Tried also: close, prompted for safe, all ok.
Reaper also has its bugs randomly.

It happens on v5.83, 6.01 and 6.02 on my system.

The conditions of the crash are as follows:

  • At least two Scalers inserted on different tracks.
  • both have chord arrangements on (not on default opening screen ).
  • one Scaler removed - save - BOOM!

I opened the “new temp” file and Reaper seems to stop saving on the writing the parameters of the first scaler plugin.

I’ve made a post on the Reaper forum too. I’ll let you know if I get to the bottom of this.
For now I’m running with one instance of Scaler per project in a dedicated process.

Also, there could be other plugins with similar behaviour, I’m still investigating…

I’ve been experiencing what seems to be the exact same issue but in Ableton Live 10. Whenever I remove Scaler from a channel, delete the channel with Scaler on, or try to save a project with Scaler on a channel, Live says it has encountered a ‘serious problem’ and will shut down when the error message is closed.

I haven’t had this issue with any other plug-ins, and I’ve narrowed the cause of the issue down to Scaler by eliminating all other plug-ins one by one. I’ve uninstalled Scaler and reinstalled it, but no luck.

Really frustrating!

Thanks for reporting, we will investigate this.

Regards,
Ed

Hello, was just about to post the exact same thing but with Logic Pro. Same exact problem. When I delete a channel that has Scaler on it or delete Scaler from a channel, it either crashes immediately or when I go to save after deleting them. I’m using the most current versions of Logic and Scaler.

Thanks
Shawn

Hi Shawn,

The workaround I use is to get Scaler to work in a “dedicated memory process”. This means Scaler doesn’t share memory with the DAW - in my case Reaper.
See if there’s a way to do that in Logic.
This doesn’t prevent Scaler from crashing but it means it won’t bring Logic down with it.

My understanding is that the devs are aware of the bug and working on it. Scaler 2 is about to be released soon, hopefully that will sort it out.
Hope this helps!

All the best,

Sebastian.