Reaper has these barriers to doing basic things


I love using scaler, just need support. Two issues that I encounter are both completely inconsistent.

1.) The drag and drop doesn’t always initiate a midi import popup that Reaper has to prompt the midi data. In fact about half the time highlighting and dragging into any midi channel to Reaper is not possible. Likewise, sometimes Scaler notes can be dragged to another Scaler, sometimes this fails also. There is a hand shape grabber showing the composition slowly dragging outside the Scaler popup (doesn’t matter if VST3 or vsti), then either the midi notes/event box appears in the Reaper timeline (success), or it does not.

2.) sometimes Scaler only presents Circle as Fifths as the only chord option. Other times the menu above Circle of Fifths appears and I can choose the other options.

There is a image of the two things at this link:

Faulting application name: reaper.exe, version:, time stamp: 0x6276d867
Faulting module name: Scaler2.vst3, version:, time stamp: 0x61948ba7
Exception code: 0xc0000005
Fault offset: 0x000000000071f0b8
Faulting process id: 0x102c
Faulting application start time: 0x01d8685aed8d0957
Faulting application path: D:\Program Files\REAPER (x64)\reaper.exe
Faulting module path: C:\Program Files\Common Files\VST3\Scaler2.vst3
Report Id: a5027c46-2750-4c1e-965a-389d7b13983b
Faulting package full name:
Faulting package-relative application ID:

Faulting application name: reaper.exe, version:, time stamp: 0x6276d867
Faulting module name: Scaler2.vst3, version:, time stamp: 0x61948ba7
Exception code: 0xc0000005
Fault offset: 0x000000000071f0b8
Faulting process id: 0x1944
Faulting application start time: 0x01d8685e78ca75df
Faulting application path: D:\Program Files\REAPER (x64)\reaper.exe
Faulting module path: C:\Program Files\Common Files\VST3\Scaler2.vst3
Report Id: 88c06b7d-1df6-4264-95af-9264c974471a
Faulting package full name:
Faulting package-relative application ID:

Graphics card is a 2080 Super with updated drivers

OS Name Microsoft Windows 10 Pro
Version 10.0.19044 Build 19044
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-M37UF68
System Manufacturer To Be Filled By O.E.M.
System Model To Be Filled By O.E.M.
System Type x64-based PC
System SKU To Be Filled By O.E.M.
Processor AMD Ryzen 9 3950X 16-Core Processor, 3500 Mhz, 16 Core(s), 32 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. P4.70, 3/29/2021
SMBIOS Version 3.3
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer ASRock
BaseBoard Product X470 Taichi Ultimate
BaseBoard Version
Platform Role Desktop
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume3
Locale United States
Hardware Abstraction Layer Version = 10.0.19041.1566
User Name DESKTOP-M37UF68\Brad
Time Zone Mountain Daylight Time
Installed Physical Memory (RAM) 48.0 GB
Total Physical Memory 47.9 GB
Available Physical Memory 41.6 GB
Total Virtual Memory 54.9 GB
Available Virtual Memory 46.6 GB
Page File Space 7.00 GB
Page File D:\pagefile.sys
Kernel DMA Protection Off

Hi Brayden. Welcome to the forum.
It’s weird what you say. I’m also on Windows 10 Pro, running Reaper 6.58. You in Reaper 6.57. But I updated a couple of days ago and I have never had those problems. Scaler works great here always. Try to update though.
I think you mean the CHORD tab. The other options are found when you go to the MOD tab.

Regarding the import of the chord names, activate the option so that it always does it, and keep in mind that the little screen in which Reaper asks you if you want to do it always appears in the center of the screen, and it is not visible if it is covered by anything else (the Scaler interface itself, for example

Appreciate the thoughts JJ. I tried uninstalling 5 versions of Reaper, 6.50-6.58, and there is no apparent difference in the random lack of functionality.

Changing the midi marker setting is not the cure. Also I unpdated C++ distributed to include 2022, but also not cured.

Yes that chord tab sometimes appears, but mostly not. This is all intermittent gremlins.

I see what you are saying about the MOD and CHORD appearing similar. with one having the drop. Perhaps this is confusion I am experiencing.

Could this be wacom related? I use wacom support in Reaper, when I try and drag with a mouse, functionality seems to be there.

Thank you JJfagot for giving me another way to think of Scaler.

I have many extensions installed on Reaper, starting with SWS. I haven’t tried Wacon though, but I don’t think it has anything to do with the problem.
Sometimes the most obvious is usually the solution. When I started with Scaler I thought I could only place one chord progression, and Scaler has so much more. Little by little you will discover it. In this forum you will always find a response from a colleague. This is the place to ask questions and suggest improvements. We all help each other. I hope you find the solution soon. I’ll try installing Wacon to see if that’s the problem.

Now I know that Wacom support is that they use Reaper with a Wacom tablet, hehehe. Sorry for my ignorance on the subject.

Hi guys,

I have just started evaluating Reaper (6.5.8) with Scaler 2.5 as I am thinking of changing DAWs. I have not had any issues dragging midi from Scaler into Reaper onto a new track. However I have not had a midi import pop-up when I have done this. looking at the preferences dialogues on Reaper I am wondering if this is something to do with importing midi markers. In your settings in Scaler is the opti0n to export midi markers ON or OFF?

Re the Circle of Fifths issue, @jjfagot is right in pointing out the differences between the CHORD and MOD panels. I believe that they have different applications within Scaler.

The CHORD panel is intended to enable you to find variations on a chord; inversions, extensions, etc (“The chord edit panel allows you to add/remove individual notes and change their velocity.” - Scaler manual).

Chord panel

The MOD panel is intended to help you “Explore more content related to your selected scale, borrow chords from a relative mode, find a secondary scale to modulate to and discover Scaler suggested progressions.” i.e. help you find chords and progressions from outside the current key, or to modulate to a new key.

Mod panel

Hope this helps

I am running on Windows 10 Home with 16GB RAM and an i7 1075 processor.

SOLVED the dragging issue!

Hi ed66,
I settled on having the setting default on with Scaler, and not adding the markers in Reaper. I like seeing the chord names.

I could imagine using the markers if I were deep into ReaScripting or using Playtime VST or some non-visual use for the markers.

Thanks for clarifying there’s different uses with the CHORD or MOD, I’ll keep adjusting as all this theory is embedding itself rightfully into my skull bacon.

I am sure that as you discover things in Reaper, the more you will be convinced.
I have Ableton Live Suite 10. I use it, of course, and it has very good things, but, since I like to simplify and use what suits me, I use Reaper more. The last thing I have scheduled is for Reaper to boot from a template with Scaler into ChordPotion and into Opus Orchestrator. And that means that every time I click on a midi file in Reaper’s media explorer I can get a pretty good idea of whether I should use that file or not. That greatly simplifies my time. If I do the same thing in Ableton or Reason, I don’t get half as many suggestions as to what might happen.
You can configure different templates. For example, with Scaler only. You will hear, when clicking on a midi in the media explorer, what it would really sound like. I haven’t been able to do this in Ableton, Reason, or RapidComposer. That’s why I make more templates and I like Reaper more and more
I wasn’t thinking of purchasing Reaper (although you can have an eternal trial license), but my friend Claudio Porcellana thought that it would be useful for me since it would allow me to divide the midi input into different channels, and that would be good for writing scores, and transferred his license to me. Thanks, Claudio.

1 Like