Rendering Offline is Out of Sync

Just wanted to let you know I found an issue with rendering using Scaler 2 as a VST instrument in reaper DAW. If I render off-line the rendered audio file is out of sync with the rest of the project. The only way to get around this is if I render it online, in real time, and everything works fine but it takes much longer.

Can you be more specific here because I am using it and not having any sync problems bouncing offline. Are you in BIND mode? Are you using an Arp? Expression? What set up and what version? And when you say out of sync what do you mean?

Bind, Arp, expression settings make no difference. The problem is not with sending midi to the DAW from Scaler 2.
I am talking about a piece of MIDI that I have on a track in Reaper already. If I then add on scaler 2 as the virtual instrument for this track to play the MIDI, I get the problem. For examle, I may already have a Midi made but I like the instrument sounds from scaler 2 and want to use it just to play the midi. When I have it set up like this and render it anyway other than off-line at one time speed, it becomes out of sync. Meaning sounds that were rendered from the midi file using scaler 2 as a virtual instrument are about a quarter second out of sync from the rest of the sounds in the rendered WAV.

Just to make sure I fully answered your question though, when I was using it last I believe it was set to use expressions. Binding was not on. Dynamic voicing was on. It also does the same thing with these are all set to default settings.

Can you post a video. Timing is tight when I try your second example for me. Whats your system and OS? Can you try VST3? I can’t replicate your issue on a Mac using Ableton or Logic. All offline renders are perfect. Finally do you have some form of delay plugin compensation causing the problem in DAW?

Here is a link to a video example

I am on a PC with newest update of windows 10. I get the same issue with the VST3 or VST2. No other effects or delays running on these tracks. Also have no issue with any other virtual instruments. I could switch the virtual instrument on the track to something different than scaler and have no issues with rendering.

Testing now this will hopefully resolve the issue. We expect it to be released next day or two. Please try it when available and report back here if issue persists

1 Like

I downloaded version 2.0.7 today and the issue is still occurring. Does not appear to be fixed.

I’ve watched your video again and its all a little odd. Its not playing out of sync, rather its a completely different rhythm, almost slurred or slower than your notes. Which leads me to think. Is it a sample rate issue? Can you try changing the sample rate of your host and then bouncing. Also can you ensure you are opening a blank scaler and bounce out scaler in its default mode (with just felt piano and no other settings)?

Hi @BornFP,

I have a question, when you bounce in audio from your midi track do your Scaler instance on that specific track has any option activated, like performance or quantise ?

Can you try this:

  • put the midi you want to bounce on a new track (not the track that has your first Scaler instance)
  • add a new instance of Scaler (don’t change any parameter on that instance) on that brand new track
  • and then bounce this new track.

does the issue persist ?

A posible explication: It happens that when draging the midi from your Scaler instance to your same Scaler track when playing it back it is then fed into your Scaler instance again and any articulation that could be applied to midi data got applied twice.

Let say you have activated the arpeggio, then your midi arp signal that you fed into your instance get arpeggiated again.

Tell me if it’s not clear.

Hope that helps,

So, I gave these fixes a try.
Changing sample rate does not fix it. running a completely clean version of scaler 2 with all the default settings does not fix it.

The only ting that fixes it is rendering it online in real time. Remember that… that must be the key to the issue. It has to be some problem with the plug in timing. Right?


Well, I think I found the fix. I set the block size for rending to auto (was set to 8000) and now it is rending fine. Not sure why this was only an issue with Sclaer 2 and not other VSTs, but i’m glad it’s working now.



Well I am glad you figured that out and good to know. Thank you for working with us on that one.