Scaler 1.2 Update

Scaler 1.2 is now available

New features:

  • Humanise Velocities: the velocity of each note within chords is randomised to provide a more natural playing style.
  • MIDI Export Length: select length of MIDI notes for export and drag and drop.
  • Improved Progression Builder: Now handles up to 16 chords & chord progression is now played at DAW tempo.
  • 21 New ChordSets: Classical (8), K-Pop / J-Pop (6), Neo Soul (6)
  • 11 New Scales: Lydian augmented scale, Acoustic scale, Major locrian scale, Ukrainian dorian scale, Hungarian gipsy scale, Melodic minor scale (asc), Half-diminished scale, Phrygian dominant scale, Persian scale, Neapolitan major scale, Neapolitan minor scale
  • Chord trigger: New trigger mode to hold notes with mouse click
  • Improved user chord-sets: Organise by folder, multi-import and new format. See dedicated post: User chord-sets
  • Bug fixes and performance improvements…
1 Like

I play a lot of sounds with a very long attack so when I press the chord button I can’t hear anything because it only lasts for 1 second. Do you have plans to introduce an option where the chords will play for as long as the button is pressed?
Thank you

Hi @jackthepilot,

yes, this will be part of the 1.2 release.
It will be optional so you will have to enable it then Scaler will remember your preference.

Excellent newz, the prefs are coming ;-))

I just updated to v1.2 but the new scales don’t show up any were, j pop and k pop also not showing.

New Scales (11)

Lydian augmented scale
Acoustic scale
Major Locrian scale
Ukrainian Dorian scale
Hungarian gipsy scale
Melodic minor scale (asc)
Half-diminished scale
Phrygian dominant scale
Persian scale
Neapolitan major scale
Neapolitan minor scale

Hi @Funksta,

You can check which version you are running by clicking the Scaler icon in the top left of Scaler’s window.
You are probably still running an older version.

You might have defined a different installation path in the installer and the previous version hasn’t been overridden or your DAW might not be configured to search for plugins in the location defined during the installation.

You can try to remove the previous version manually or using the uninstaller through the Windows settings then reinstall the new version.

Hi Ed. I did that already. Cleaned all the files out cleaned my registry etc and re registired scaler again so it was a clean install on windows 10 and studio one version 3.5.6. I tried both vst 2 and 3. For some reason also when you drop the vst3 file in common files the vst2 version disapears from studio one’s plugin list and only shows vst3. The installer installs the vst3 file in the same place as the vst2 file hence why i had to move it. It installs in the wrong place and not common files vst3. I Downloaded the update from plugin boutique if it helps at all. But i have the exact same scales as i did in v1.1.1. Classical and neo soul are there and the new features work fine but K-Pop / J-Pop (6) and all the new scales are simply no were to be found in the plugin. Also tried Cubase and it was the same.

Should the new scales show up in type all drop down? If so there not there at all.

Regards: Funksta

@Funksta, it looks like the installer you have is the old one.

The VST3 folder issue has been fixed in 1.2 so you shouldn’t have to move the vst3 file after installing it anymore.

Try to re-download the 1.2 installer from Plugin Boutique’s website.

Thanks a bunch for the quick turn around on the issue i had Ed. Everythings working perfect now. Many thanks for the help and fast response time and keep them nice updates coming ::):grinning:

Best Regards: Funksta

1.2 update for Mac from works partially. Deinstalled it after not being able to install the new update. Re-downloaded file. Re-registered license. Scales don´t show up. Classical showed up while others didn´t . Humanize doesn´t work. I am on 10.13.3.


Didn´t realize velocity is humanized. Works when dragged. New scales and K-Pop/J-Pop dont show up.

Hi, same issue than Funksta with version 1.2 update on Mac. No new scales and neither K-Pop / J-Pop. The the other new features like progression and humanize are working Ok. I downloaded the installer and tried to reinstall again without results. Thanks

Some users are experiencing an issue with the link to the 1.2 installer on the Plugin Boutique website.

While the issue is getting resolved, I have contacted those users privately and sent them an alternate link to download the installer.

It is unlikely that some features are available while others are not, The K-Pop and J-Pop chord sets are located under the same submenu (J-K Pop) in the “Songs” dropdown, you should also see the new “Neo Soul” chord sets.

To check if the scales are present, go the the “Scales” screen, in the “type” filter dropdown you should see the new scale types (Acoustic scale, Major locrian etc…) in the second half of the list.

Guys, I’m just confirming that the correct version of 1.2 is now being corrected on the PIB site. Should be live within an hour or two. Apologies for the confusion, PIB linked to the v1.1 version.

Ed thanks for the private link. Everything works now nicely. Link on PIB was a smaller file.

The new scales are not showing up for me as well. Just downloaded from Plugin Boutique, Saturday Mar31, 2pm EST. Also, vst3 appears to be 1.1 while vst2_64 is 1.2

The 1.2 installer fixes an issue with the VST3 location so you might need to manually remove the previous VST3 file from the folder and configure your DAW to search in the correct VST3 location. More info on VST locations:

I re-installed and the vst3 file goes to same place as vst2 and the new scales do not show up. Are you sure the installer at Plugin Boutique is fixed? BTW, I moved the vst3 file to proper directory and it is the 1.2 version but alas, no new scales. Also, the Neo Soul new sets are there but not the K-Pop and J-Pop chord sets.

Tried again, d/l from pib, re-installed, same thing. No new scales. I can send screenshots if necessary.