Scaler 1.5 - Announcement

The next version of Scaler is almost ready and is planned for release in September.

The update will be free for current users and brings a lot of improvements.

New Features

  • Chord Editing
  • New UI skin
  • New chord sets (Cinematic, Joseph Greer, The Temper Trap, Mitekiss)
  • New sounds (String Ensemble, Electric Guitar, Acoustic Guitar, Harmonic Guitar)
  • Guitar Fretboard visualisation (with support for 20+ tunings)
  • Arpeggiator (3 patterns)
  • Strumming (3 profiles)
  • Parallel Harmony
  • Multi Selection of chords
  • Scale Lock
  • Relative chord finder
  • 32 chords in progression
  • Undo-Redo in progression

1.5 Update overview video (private link):


Beta access
If you want to try this beta version:

The support we provide for this beta will be limited to bug report and fixes.
The updated manual isn’t ready yet and you will have to discover the new features by yourself.
If the current version of Scaler works on your setup, you shouldn’t encounter too many issues. But this is still a beta version so your experience may vary.


Can someone please tell me what scale lock will do?

Also will the various sections in scaler be expandable up down and left right to fit more on the screen. The side scrolling thing on the chord lists and the tiny scale selection window doesnt cut it for me.

Scale lock allows you to block notes outside of the currently selected scale.
You can use it to experiment or play melody that fit your progression.

Regarding the interface, there is no expandable panels. But there has been a refresh of the UI to allow for better usability.

11 posts were split to a new topic: 1.5 Feedback - Suggestions

It would be good if keys not in the scale when scale lock is off are dark grey instead of white so the scale can be seen easier. Or perhaps just make the entire key blue instead of the tips. It just isnt easy on the eyes.

Im still getting hung notes in scale lock mode on my hardware. This happens when I hit a key outside the scale but it forces that key to play the correct note in the scale. hung notes.

For example IM in D Mixolydian mode and I hit F to F#

I set the output port in Fl studio (Scaler) to port 0 which is my external gear. and set my hardware to midi channel 1.

Nice job so far …

Thanks for the feedback, I will have a look into this before the release.

If the keys were to become solid blue, it would conflict with the “currently playing” notes.
We’ll have a look at what we can do to make it more visible.

Does it reason 9 support

The compatibility should be the same than Scaler 1.2. Reason 9.5 & 10 are supported.

Due to Reason not supporting MIDI routing, you will requires extra tools to control external instruments, but everything else is supported.

Hi there! This plugin is simply amazing. One feature I REALLY like that you’ve added is the strumming/arpeggio option. I have a problem though. I can’t hear anything coming out of the chords when I check either of those options.

I’m on the latest Logic Pro X. I can play chords and notes and pretty do anything I was able to do before, but I’m only encountering issues when I check the strumming or arpeggio boxes. Is there something I’m doing wrong? I can’t find anything related to my question since this update is so new. Thanks in advance!

Hi @Clormo,

I just tested, and cannot reproduce your issue here on Logic.
Are you using the MIDI FX or Instrument ?

Both Arp and Strumming features are using the DAW tempo to function. Try to change the tempo of your track and check if the problem is still present.

Thanks for the quick response. I tested with both the FX and instrument and no luck. Once I check the strumming box, there’s no chord that plays out any sound. I’ve tried both the artists “A” row chords, the “B” row scale chords and dragging them into the “C” row and nothing.

The piano or fret view show the notes that make the chord, but no sound is coming off when I press any of the chords. It is very strange. Once I un-check the strumming box then the chord plays sound as usual. I also changed the tempo as suggested and still nothing. Also just restarted the app just in case, but it is still happening. I’ll give it a few more tries tomorrow. It might be something simple, just wanted to point it out in case someone else encounters it. Thanks again.

Hello, this is an issue for windows as well. Using Ableton live 9 when strumming is selected the chords will not sound and do not show any strumming notes. This is using the internal instruments as well as plugin instruments on another track. When strumming is deselected the chords will play as normal. The arp functions as normal though. Thanks.

Hi @Roc,

thanks for reporting this.
I have tested on Ableton Live 9.7.6 on Windows and cannot reproduce your issue either :confused:.

I have tested with different tempo, different sample rate and buffer size. The internal sounds always trigger normally.

I will keep on investigating…
Could you give more info about your operating system and which version of Live you are running?


Sure, Windows 10 and Ableton live 10.0.3. I also checked in Reason 10.

Without arp or strumming selected:

Using a mouse, Chord pads and the greyed out (midi bind) notes will sound when clicked, playing the chords with a controller works as normal.

Arp selected:

Using a mouse, Chord pads will not sound when clicked, the notes are highlighted to relect the chord change but the progression through the arp doesn’t happen. The Greyout (midi bind) notes on the keyboard will play the chord (arp) when clicked and Playing with a controller (midi bind) will play the arp as normal, with the arp progression highlighted as it is played.

Strumming selected:

Strumming doesn’t work with mouse clicks at all, Chord pads or The greyout notes on the keyboard. When I click the chord keys on the gui keyboard or the pads with the mouse I get no sound. When I try to play the chords on my controller (Akai advance 25) with (midi bind) the gui keyboard and pads will reflect the chord change but no sound is generated, and the notes don’t show the strumming. Un-select strumming and the chord will sound as normal.

This is my exact same scenario. I tested it multiple times for the past hour and it all happens the same way you describe but in Logic Pro. It is super weird. I wanted to ask the following even though I don’t think it would have an effect, but maybe? I also have InstaChord installed. IC has similar strumming features. Could it be a conflict between plugins? I don’t have it active so it doesn’t sound plausible to me, but wanted to throw it out there just as a data point.

In my case, the Arp works sporadically with mouse or MIDI controller. It’ll work for a few progressions sometimes and others won’t make any sound at all. Can’t wrap my head around what it could be though.

What is he doing at :40 to trigger/generate the sounds for Temper Trap? I assume he’s pressing midi with his non-mouse hand or something… I don’t assume that the strumming begins just because he selected “Strumming,” but please advise. Thank you!


Using the bind midi function, you can trigger chords using your midi controller.

The Arp, clicking the chord pads works with the following setting.

Check: Control note durations with mouse click

With this setting off, the arp will not sound and the gui will not progress through the arp when clicking the pads with the mouse.

Clicking the greyed-out chord keys on the virtual keyboard with this setting off will works as normal. Midi bind using controller works as well. So its not consistent, maybe a bug.

Strumming still isn’t working for me no matter the combination of settings.

Windows 10, Ableton 10.0.3 and Reason 10.