Scaler 1.8.0 and 1.8.1 EXCEPTION LIVE 10

Hello, suddenly SCALER creates an exception in Ableton Live 10 WIN 10. I have to uninstall it and then everything is fine.

I do not have SCALER 2. I have the regular SCALER.
It is located in a custom VST2 folder.

I went to Plugin boutique and saw that 1.8.1 was available.
I downloaded and installed: SAME issue. I had to uninstall.
When uninstalling, even though I downloaded 1.8.1 from Plugin Boutique, WIN 10 uninstall lists SCALER as version 1.8.0

So I paid for something I can no longer use. Please help. Thank you very much.

Hi @lys_knight

Scaler 1 does not support being moved to a custom location really well. Have you tried to reinstall it in the default location?

You are saying it suddenly appeared, have you updated Ableton Live or Windows recently?


Ed thank you.

I would have never ever bought a plugin that I cannot have installed in a custom folder. If that is the case this should be disclosed .

Thinking about it, yes, there was a big windows (2004 I believe) update recently.

When I was no longer able to open my projects I opened the DMP files generated and it is where SCALER was listed as the issue. It is the only plug in that no longer works. I have about 80 vsts that work just fine including Roland Cloud and Arturia V collection.

Now the question is, is ‘Scaler’ going to give me (no fee) an update for something that works? I used to love using Scaler and I’m so sad I can no longer use it :frowning:

Hi @lys_knight

Thanks for the additional info, we will do some testing with the latest Windows update and see if there’s anything going on.

Have you tried the demo of Scaler2 to see if you had the same issue?


As per your recommendations I’ve just tried the SCALER 2 DEMO and I had no issue.