Scaler 2.07 Bitwig 3.2.2 issue..?

:wave:…just installed scaler 2 on a new Lenovo flex 5 amd 4000 laptop…it’s working good with Ableton…but in Bitwig it’s not fully there the dimensions are off…not useable at all…I changed the scale 75%- 175% view in Bitwig but didn’t help …reinstalled nada…all legit software

1 Like

I don’t know if 2.0.8 will fix that but you do know that it’s out right?

Hi! I have Bitwig Studio 3.2.3. Not able to launch scaler 2.0.8

Linux, Windows, or Mac?

Its on Windows 10. I just purchased scaler 2.0.8. It looked so promising. But when I tried to launch the program into an instrument track… it keep crashing everytime I reload.

So I’m on the same setup and it works every time. Are you using the VST or VST3 version? Did you install it while Bitwig was running and have you quit and restarted Bitwig? I’ve dragged and double clicked it on to Effects, Group, Audio, and Instrument track without issue. In your Bitwig Settings what Mode are you hosting VST’s in? I’m set to “By Manufacturer”.

Scaler 2.0.8 vst plugin got installed into the directory C:\Program Files\Steinberg\Vstplugins. Under Settings -> Locations in Bitwig I have disabled “Prefer VST 3 over VST 2 (when available)”. Under Settings -> Plug-ins I could see only Scaler 2 (VST 2.4) and ScalerAudio 2 (VST2.4) , tab selected is ‘By Manufacturer’. So, I guess I have only got VST 2 for scaler. Are you able to toggle between VST 2 and VST 3 for scaler?

Hey dude! I guess I got the issue… My Bitwig studio starts by default with Nvidia high end graphics processor. I have forced it to start with Intel graphics processor… it is now able to load Scaler 2 properly. Thanks a lot! Will get back in case of any issues or queries. Thanks again.


Scaler 2 has been causing my Cubase to crash since its release. After reading this thread I set in the NVIDIA Control Panel to run Cubase on the integrated graphics card. Now it works! Finally! Thanks guys for sharing your experience. I believe Scaler 2 must be patched for this. A plugin having compatibility issues with your graphics card is not acceptable.

1 Like

Hi @scaler2heaven

could you check if the 2.0.9 update has solved your issue?


Hello @Ed1!
Unfortunately, it has not. I still have to configure the NVIDIA control panel.

@monojgogoi How and where do you find the configuration between Bitwig and NVidia? I’m not finding it. I’m trying to replicate things by switching between the two as I have Windows 10, GTX 1080, and Bitwig 3.2.4 along with Scaler 2.

@unity2k I have the Bitwig Studio shortcut on my desktop screen. You can start it by right clicking it first -> Run with graphics processor option -> High-performance Nvidia processor.

@unity2k Or you can also set it by first just right clicking on the desktop screen -> NVIDIA Control Panel -> Manage 3d settings -> Program settings -> select Bitwig Studio program. Then you can start your Bitwig on NVIDIA graphics processor… As mentioned in the previous comment. This should help replicate the ISSUE that was faced earlier by me. So, to resolve the same I start Bitwig by selecting Run with graphics process (on right click option) -> Integrated graphics. This helps run Scaler 2 run smoothly.

Again this issue has been for Scaler 2.0.8 with Bitwig 3.2.3 running on NVIDIA graphics processor. But with Integrated graphics, Scaler 2.0.8 runs as SMOOTHLY as butter and I am loving it :slight_smile: . I do hope this issue gets addressed soon in the upcoming versions.

Thanks for the quick reply, this is not an option on the desktop that I can find. Maybe it’s a notebook only thing? Anyway, thanks for helping bring clarity.

1 Like

My setup of Bitwig 3 and Scaler 2.2 is working fine.

1 Like