Scaler 2.1.2 constant crashing in Reaper 5.x and 6.x


I just bought the Scaler 2.1.2 and I haven’t been able to use it more than 5 minutes per time. It seems that it crashes latest 5.x versions and newest 6.x versions of Reaper no matter what I do. I even tried using other than ASIO audio drivers and it did not help.

I am very unhappy about this 50€ worth of *.

Best Regards

the life of digital musicians is hard indeed

I had many crashes with Ableton Live 9 and Scaler 2.1.1
I downloaded then the demo of Reaper 6 finding it able to manage Scaler… only apparently because after a few test I found it crashed again
tried debugging to no avail

in the meanwhile Scaler 2.1.2 jumped out but crashed Reaper 6, so I came back to my Ableton Live 9 and it works like a charm now :astonished:

I used tons of softwares since the first IBM era, but it seems to me that musical software crashes are hard to understand

I hope you find a solution, maybe with the new update that is close to jump out, because Scaler is a wonderful tool

Hi mrmarshbank,

I’m sorry to heard of your issues. I am sure the Scaler support team will take in account your problem as is usual from them, however i want to do my bit about it.

NOTE: This is only in the case you are a Windows user. I am also aware of the different conditions of each user in terms of hardware and the system itself.

I am new to Scaler since version 2. I have used it in Reaper 6 with Windows 7 and 10 on two different PCs, without problems except for the occasional issues reported by all users and which have been fixed until update 2.1 .2.
I have not had massive crashes or freezes, and sometimes I have worked up to 12 continuous hours without stopping or restarting, except when the cause is other factors (including the frequents blackouts in my country)

I think, about Windows, it would be convenient to check the most recent OS updates, also check the libraries such as c ++ redistributable visual studio, the .net core and other system related resources, which could be invoked by some plugins and of which there is information on the net.

As a proof of the stability of my system with Reaper and Scaler 2, I have several projects like this ones I have released here in the forum.

Good luck!

Yes, still a bit suspicious to sell a “beta quality” product software-wise. Clearly not enought testing behind this product, as every other VSTi works in my system, and similar reports from others as well.

I finally managed to get Scaler 2.1.2 to run when I downloaded this:

With this software I am able to use MME sounddriver and run Scaler separately from Reaper that is using ASIO drivers. Then I am able to drag & drop chords and progression to reaper still from Scaler.


I finally managed to get Scaler 2.1.2 to run when I downloaded this:

Great, I was near to point you to it yesterday but a blackout hit and got off line. Nanohost is a perfect and free test field for VST, and it is VST3 compliant. AS I said, I use Reaper and will be attentive to your reports, I hope your issues be fixed.


I checked the tool but I don’t understand why it is able to fix that issue?
is it related to the audio driver?
and, I read the MME is usually useless, and ASIOs are always a better choice

mmm maybe I got it: the nanohost transforms in real-time the plugin output in a vaw file, so bypassing the interaction between Scaler and the audio driver

I honestly haven’t had any problems with Scaler 2 in Reaper (Currently on V6) however my demands are probably less than most users. I’m primarily running Kontakt , a few Spitfire libraries and the Ember tone 1955 plus a couple of vocal libraries .

I don’t complete projects in Reaper as I prefer finessing and mixing down in AUM so Reaper is solely used for producing stems from instruments which are awkward to interface with my IPad .

Best Limbic

Same here. Recently upgraded to Scaler 2.1.2 and Reaper 6. Software very unstable, crashes almost every time i use it, seems to be particularly when expanding the screen to show more than 8 blocks.

Whilst Im moaning… the screen fonts and colours remain difficult to read.