Scaler 2.1.2 - Everything but rest play through

Thank you so much for the great update. All the main problems have been fixed for me except the play through rests when closed. Scaler plays through rests when open but closed it just stays on the chord before it or stops. If I have 2 instances of Scaler synced to DAW, if the one closed hangs on a rest while the open one keeps playing, if I open the closed one it starts playing through the rest and is now out of sync with the open one.
Again, most of the bugs I was seeing are gone except this one.
Thank you.

ADDENDUM: Just playing with Scaler 2.1.2 and just found that if I leave the All Pattern matrix open and close Scaler that it will play through the rests now. If that’s the case I can live with this quite easily. Will play with it some more.

ADENDUM 2: Rest play through seems fixed as long as the Pattern Matrix is open when you close Scaler. Scaler will not loop if there is a rest at the end of the pattern but there are work arounds. Thank you DEVs for fixing this as I like using rests sometimes when exploring patterns.

Hi @jamieh,

Thank you for your feedback. I am glad that the fixes are helping you make use of Scaler as you wish.

About the rest issue with the Chord Pad view closed, we have been testing with various setups to try to replicate what you are experiencing, but unfortunately, with no success, playing and looping Rest with daw sync is working fine on our side.

To find what could be going wrong, could you please elaborate a bit more on that issue and, for instance, give us a specific replicable scenario to achieve it?
What tempo/time signature you are using?
How many Rests are involved?
Are you using specific Playback Matrix values?
Any info that you think could be of any help for us to replicate the issue.

To give you one example of a working scenario, we have been testing to replicate your current problem according to your description.
For instance, we tested with Mac OS (10.15.6) inside Ableton (latest version: 10.1.18), the VST2 version of Scaler 2.1.2.
We load Scaler on the new Ableton project inside the first track (BPM 120; 4/4).

We create one pattern with one chord in position 3; the other slots are sets to Rests.
We let the Playback Matrix values standard, without activating any performances…
We toggle the Scaler Looping on and enable the Scaler daw sync; we set the chord duration to 1 BEAT.

Now with this precise setup, when you press the Ableton play button (or space bar) to start the host playback, the Scaler playback start, and no matter if you open or close the Chord Pad view, open or close the Scaler UI, the chord and Rest are played, and the pattern is looping correctly.

Is this specific setup working for you too? Or are you experiencing the “Rest play through issue” with the latest version of Scaler within this particular scenario?

Hope you could have a try with these simple instructions, if you need any help or have any question, please come back in this thread.


Let me try this, I found last night that the original session still does not work closed which is frustrating and Rests don’t work looping if at start or end. Now to be clear - Scaler works fine when it’s open but not when it’s closed in my set up. I will duplicate yours and see.

1 Like

OK, some interesting results that seems to center on beats 4 and above. If I create your session it works fine. So I went back to one of mine and did some tests. My Default beats was set to 8 beats. This one does not work right.
If I have everything set to 1 as you did I can get this session to work-

If I set the session to this - 4 beats duration it does not work closed -

This combination does not work either-

It is interesting to note that the ones that do not work (i.e. stops at the rest), if I close the UI while it is playing it will continue to work after I start and stop it closed sometimes. This is what fooled me into thinking it was fixed.
If I increment up the duration from .025 up to 4, it stops working at 4.
ADDENDUM: If I set just the 1st rest to any duration BELOW 4 it works correctly.

Thank you @jamieh for those details.

Curious that no one else has this problem. @luapmartin have you had any luck in replicating this issue?
Maybe I’ll see if I can try it in another DAW and see if I can replicate it there.

1 Like

Hi @jamieh, yes, thanks for your valuable feedback, we are indeed working on a fix.

Indeed a interesting issue, and you both have done a great tracing and testing procedure. Would it be worth testing in Reaper or FL Studio on Windows? Or is it something specific to Mac and Ableton DAW? count on me to do it.

I don’t know. I encountered it but I haven’t seen any others say anything about it so it might just be a Mac thing.