Scaler 2.1.2 - Notes Hanging all the time

Hi all
I’m new to Scaler and new to the forum, so thanks for having me.

I’ve looking across the forum but couldn’t find a resolution.

Anyone have/had a similar issue and a solution hopefully.

Using PLX and Scaler2 as a VST… Hangs of the notes literally every session. No issues on any other VST

Here’s hoping, Cheers, Mark

Please make sure “latch” is not enabled:

Thanks for that… had a look in the preferences and it was set to ‘chords only’

Should Midi have an

Exclamation Mark next to it??

Not too many people notice the exclamation mark! :wink:

If you hover you will see, “Midi Panic: Reset jammed midi notes.”
If you click on [MIDI !], “MIDI Panic” will display.

In most DAWs and some keyboards there is a way to send Midi Panic to turn off stuck midi notes. In Reaper it is the function key [F3]. In Scaler you can click on [MIDI !]. In other DAWs ymmv.

1 Like

Normally this would indicate that your devices are getting NOTEON messages without receiving the corresponding NOTEOFF messages. This can happen when notes are allowed to overlap, i.e., the same note is played on top of the next note. I really don’t know why this happens, really, but I suppose that midi applications don’t use a counting buffer per note.

You would think that {same note} NOTEON, NOTEON, NOTEOFF, NOTEOFF or NOTEON, NOTEOFF, NOTEON, NOTEOFF would be equivalent, but apparently there is a problem with the prior as it has been reported to be a problem known as “overlapping notes”.

In Reaper when editing midi, you can click a button to “fix overlapping notes”.

Note: Other than that? One of the devs might have to chime in, or you can contact them directly via email. They will need information about your setup.

It would really be a big help if they can duplicate the problem to come up with a solution. The problem is, that unless they can re-create the “same” problem, there usually isn’t a clear solution.

1 Like

Thanks again, I looked and couldn’t find any developer email… don’t suppose you are in the know?

welcome @MJB Could you elaborate please. notes hanging when? What is your setup? DAW, OS, platform?

Hi there

Pro Logic 10.5 on a MacBook. Open the daw, load up Scaler 2, and run through any of the features. Play a combination of chords and I’ll get a note hanging every time without fail. Click on the midi panic button and it kills the tone until the next progression. Not a hill to die on but bloody annoying. Any help appreciated

Got to be something unusual about your setup. Does this happen when Scaler is loaded as an instrument of assigned to another via Midi FX? Do you have a controller? Is there a routing problem in Audio Midi Setup on your MB? Bottom line is something is wrong and most likely (given I and thousands of other users share your setup) something particular about your setup.
Try disconnecting all controllers USB devices. Load Scaler as an instrument and try again. Load Scaler as a MIDI FX and assign it to a Thord party VST and try again.

Thanks David. I’m loading it as a instrument every time using the Arturia Keylab 2 as the controller. I’ll do as you suggest and load as a midi fx.

I have a new issue, schoolboy error… upgraded to Apple Big Spur… I’m assuming Scaler2 isn’t compatible yet?

Thanks for an invaluable solution by the way!

EDIT: just got home and tried loading as a FX, no midi hanging issues. Tried it as an instrument… no issues either?

So, just waiting on a full compatibility with Apple’s Big Spur. All seemed to be solid apart from performance…if you need a beta tester I’m here :slight_smile:

Good to hear its working as far as Big Sur we haven’t gone there yet. We are deep in development for 2.2 and very excited for its release in a few weeks upon which we will have a look at Big Sur. We presume it should work, what’s your experience with it so far?

1 Like

For my work I mainly use it for Final Cut Pro and Pro Logic. So far its looking solid.
Looks and feels slicker, hopefully giving some more years to come on my 2016 MacBook. Third party software seems good including Scaler 2 - excluding the Performance Elements which are shot to buggery to be honest. Which is a shame because their were helping and teaching me immensely… looking forward to getting it back in due course :slight_smile: keep up the great work!

Sorry if I’m being dumbo here, but Scaler 2 is sticking ALL of my notes on startup (as midi FX and as instrument) with my NI s88 controller (even with sustain pedal unplugged/ midi cables out). I open up Scaler 1, no problems with hanging notes at all. I tried using another controller and the hanging notes problem disappeared…I’m wondering if it’s NI I should be contacting but it’s weird how it only happens with Scaler 2. I checked that Latch in prefs is off and I’ve tried everything in this thread but no joy…guess I’ll stick with Scaler 1 for now. Unless I’m being blind?

Logic X
IMac Pro 2017
attached is a pic of me playing an octave on startup (without holding the notes obvs)

Same issue here on Reaper. Here’s a video:

It’s intermittent, but happens way more often than not. You can see after the MIDI event is processed by Scalar, it keeps sending the stuck notes to the synth channels.

I tried several MIDI filters and different other workaround, but it really seems like it’s Scalar that’s sending the MIDI to the channels after it should be done playing.

I’m using Reaper 6.15/x64 on a Windows 10 machine.

1 Like

what’s that?
how is possible doing that?

I looked the video for Ableton and it shows what I do usually

I asked because I have notes hanging quite often and I hoped it was due to a wrong workflow I used

Oh, great. It happens to me in Reaper from time to time and I was not able to stop the hanging note. I didn’t check for shortcuts earlier because this does not happen often and I was a bit lazy, so thanks a lot for this tip.

I just found that, in my system at least, notes never hang if Humanize is deselected
I hope it helps

1 Like

This would indicate that there is a bug when Humanize is turned on causing the same notes to overlap and therefore midi is not getting the correct number of note-off messages. :wink: Good find!

1 Like

I discovered this too and Devs are aware. Part of the reason we’ve pushed 2.2 back to December 10th. Hopeful of a fix.


the other part is that the next release will let me play as Rick Wakeman in The Six Wives of Henry VIII

1 Like