Scaler 2.1 - no sound, no MIDI (Logic Pro)

Fresh install of Scaler 2.1, first time user. Logic Pro 10.4.8, OSX 10.14.6.

• When loading Scaler as a software instrument in its own right, there is no sound, shows no evidence that it’s receiving MIDI.

• When loading Scaler Control as a MIDI FX plugin on a channel that already has a software instrument loaded, scaler simply renders the track mute. Disabling Scaler Control lets me hear the track again.

Several days into fighting with this plugin, yet to hear a sound. I have followed all steps outlined in the troubleshooting documentation at

Bug? Or idiot user? Hoping someone can help.

Logic X 10.4.8/OS 10.13.6 - I added Scaler 2 as an instrument and it plays fine. New track with Scaler2 as MIDI FX with a piano loaded as the instrument and it plays fine.
Created a electric piano track and added ScalerControl2 and it played fine. I can’t duplicate what you have happening.

Same problem here on LPX 10.5.1/OS 10.15.6. What’s strange is that during the beginning of my trial period it worked fine, then stopped with about 9 days left to the trial. Assumed it was just an issue with the trial period, showing the wrong amount of time left or something along those lines like a dummy, pulled the trigger on buying the license and still not working at all.

Can you take a screen shot of Scaler in your setup?

Many thanks for the replies. Fixed now…•blush•…I basically turned off my Mac and turned it on again, and Scaler is now behaving itself (although in my defence, that’s not the first time I had tried that).

Hopefully all good from here, looking forward to diving in.

Scaler 2.1

No sound
No midi

Scaler 2.09 wasn’t working then it started to work suddenly (for no reason - I haven’t even restarted my workstation in weeks.

Now this. Hope you solve this issue because it’s murder for an otherwise amazing piece of software.



We are now all using the updated 2.2 version of Scaler which includes a lot of bug :bug: fixes and other goodies.

Try it out and get back to us if you are still having the same problem.