Scaler 2.2 upgrade and always notes stuck in performance mode

I was waiting for Scaler 2 upgrade 2.2 and installed it today.
But still the same bug : notes stuck in performance mode with FL Studio 20.7.3 or Cubase 11.
Try to use Scaler 2 with Ableton 10 Lite : no problem in performance mode.
How to resolve this issue because I use FL Studio or Cubase and no other one DAW.
I’m disapointed cause I hoped this issue resolved by the last upgrade and cant use Scaler 2.
Any idea ?


Hey @Alain85100

are you sure both software are launching the same version (2.2) of the plugin?

If they are both on 2.2, try to check your audio parameters in the different DAWs. Check if the working ones in Ableton are any different than FL or Cubase.

Hey @Ed1,
The same and latest version of the Scaler 2 plugin (2.2.0) is used in FL Studio 20.7.3 and Cubase 11.
The settings are also the same.
Scaler 2 is the only plugin that give me this issue.
I saw in the Scaler 2 forum that some users had the same issue and hope the new Scaler 2 can solve it.
Perhaps a difference with OS, I saw all the videos about Scaler 2 and these demos are made on MacOS and not on Windows 10 as host.
Waiting for a strong solution for use Scaler 2 !

I’m still waiting a solution for the stuck notes when playing chords or melody progression in performance mode.
I’m using FL Studio 20.7.3 or Cubase 11 and have this issue using midi controler but also without midi controler using only the mouse of my PC to click on chords or notes of the virtual keyboard.
Now I cant use Scaler 2.2 at all for creating chords progression or any melody.
I hoped the new Scaler 2.2 release without this issue but still not resolved !
Waiting for a real solution.

Hey @Alain85100

thanks for the extra information, we are already working on it and expect to have it fixed in the next patch.
It takes a bit of time but we are on it.

Hi, can confirm I have the same problem in Logic 10.5 w/2.2 – performance mode leaves odd notes hanging on release. I have to turn Scaler off and on again to release them.

(that said, I only discovered Performance mode this week and it’s marvellous)

Just to note… i have the same issue in Studio One 5.1.
I’ve noticed too that when switching Modes from the right side menu, I get a single note ringing out, usually F above middle C. It just rings out and sustains for awhile. Don’t know if that is also related to this stuck note issue; might be though.

Graphics/Audio drivers are up-to-date. S1 is also up-to-date.
I don’t have this issue with any other soft synth or VST plugin in my collection.

I ALSO have another more serious issue, but i will open a new thread for that.

I’m a new user but I am getting stuck notes and using the midi panic button frequently in Studio One Pro version 4. Thanks

Same problem in Cubase. Stuck notes and I need to press midi panic to stop them. But they reoccur right after anyway.

Same issue every time performance mode used (for certain performances - see below)
Scaler 2.2 VST
Studio One Win x64 (Built on Nov 13 2020)

Testing notes:

  • Issue occurs with both VST and ScalerAudio as an insert
  • Same stuck note(s) every time
  • DAW panic button will not kill note
  • Scaler panic button will kill note
  • Turning off Performances will kill note
  • Some chords will kill some notes
  • No other VSTs (including scale and chord tools) cause this behavior
  • Stuck note(s) does not pass state onto external instrument (but stays stuck w/in the Scaler UI)
  • Does not occur on all performance modes
  • For example Arpeggio - sticks, Strumming - none, Performances/Accento - sticks, Adagietto - none…

To Replicate:

  1. Select a Scaler instrument
  2. Select C maj scale
  3. Turn Performance On => Arpeggio
  4. Click and hold 1st chord for a couple cycles of the pattern and C will stick
  5. Click and hold 2nd chord for a couple cycles and A will stick
  6. Next chord…and so on


FL Studio user here and I have the same problem (Win 10 / latest FL Studio version). Scaler 2.2 produces weird hanging notes that does not follow my chord-progression when in performance mode. I’m talking a simple and perfectly quantized midi chord progression that I can play with any other VST without a problem. When performance mode is off it plays the exact same chord-progression flawlessly btw, so the performance “engine” must have some kind of bug I think.

I really hope you guys can fix this, because the patterns in performance mode are freaking awesome and could be a HUGE help in my productions.

Cheers from Denmark

Peter…you’ve probably already found this, but if you use the play mode within Scaler, the notes do not hang. On my systems, the hanging note(s) seem related to the triggering mechanism. If I use an external trigger for Scaler (click a chord with my mouse, hit a key on my keyboard, tap pad on my ATOM, program a midi note in an event) the notes will hang in some performance modes.

However, if I just click the play button w/in Scaler (or in my DAW w/synch turned on), no hanging. I need to program a pattern that I want, but at least I can use the Performance mode to pull some midi. Not an ideal situation, but as we wait on a fix, it might be a workaround you could leverage. One of the upsides, it is a great reason to dig deep in to the coolness of the Pattern Editor. :slight_smile:

Hello, it’s a good compromize, thanks to you !

TMacD yeah im aware of the player inside Scaler and you are right, the internal player does not cause hanging notes. But when I browse the Scaler patterns I want to listen to them along with my mix/DAW. But now i’m using “Chordpotion” instead while I wait for Scaler to fix this bug. That works perfectly and fits my workflow better :slight_smile:

Thanks for the tip, it’s a good one that i doesn’t heard of before, now in my collection!
The time the bug will be found, we gonna learn how to not need to use scaler2…sad

Confirmed behavior in Reason Suite 11. Very annoying.

Yeah, happening here too, I’m afraid.

I’ve also experienced occasions (although rarer) where removing the plugin from the channel strip results in a complete crash of Logic (version 10.5.1). I have noticed no particular pattern to this - it’s happened on small projects and big ones with all manner of VSTs.

Look forward to a fix. It’s a wonderful plugin and I’m enjoying the 2.2 upgrade.

Hi there.
I am using 2.2 version (trial) and the same problem here : many notes stuck in pref mode…
The way i “solve” this issue, in my case :
In setting panel , go into expression option and then use (click) latch and chord only (play quantize must be enable).
That way : no more any note stuck, even it’s ok, it’s a latch mode… but to work (for me) it’s better than background note.
I ll wait to read that problem will be fix to buy this nice vst.
Hope that can help anyone.

1 Like

Welcome DrFalco

I believe they worked out the stuck note issues in the current release 2.3.1. In full transparency, I still get a rare one, but for the most part it is a function of running very fast progressions on a old laptop with stock drivers. I’ll certainly try your “solution” if they creep in again. As I can’t play worth a darn, I work pretty much exclusively in Perform mode so stuck notes are always top of mind for me.

FWIW, and if you are on Windows, getting off the Windows sound drivers and going to something like ASIO4All and then tweaking the buffer size made a huge difference for me. If you are new to Scaler, you will likely find it an amazing tool for a broad range of uses and users. I’d buy it again and again…without question!

Thanks again for the tip!