Scaler 2.3.0 and 2.3.1 don't receive or transmit midi as a Unify MIDI Effect

I hoped v2.3.1 would fix it, but Scaler inserted as a MIDI Effect to Unify (standalone) v1.4.0 doesn’t seem to receive or output midi.

For example, when I press Record and play my keyboard so Scaler can detect a scale, I see midi in Unify’s MIDI Monitor just before the Scaler instance. But Scaler isn’t recognizing the midi. Also, if I select a scale in Scaler and use my mouse to play Em, there’s no midi output to the second MIDI Monitor in the signal path. Only when I bypass Scaler does midi pass thru.

I hope the attached screenshots make sense. Other MIDI Effect plugins work, although there are a couple third-party ones that seem to have the same issue. (Obelisk 1.1.6 AU, and Phrasebox 1.0.7 AU.) Running Big Sur 11.2.3.


@getdunne @Ed1

Hi @eakwarren

thanks for reporting your issue. Are you running this on an M1 machine?

If yes, it is a known issue, Logic Pro is affected as well. We are working on it.

Hi @Ed1

Thanks for the quick reply. Nope, Intel. More info may be found in my PluginGuru forum post where Shane responded. Something’s not communicating with the other something, somewhere! Thanks! :slightly_smiling_face:

Hi @eakwarren , when I tried to repro this on my Unify/Scaler2 configuration (and it works actually), I noticed one difference:
Your screen showed Scaler as “MidiFX”:

Mine showed one of the built-in instruments. I don’t have a “MidiFX” option there, so I am wondering if you are running one of the alternate plugin versions of Scaler in Unify.

Hi @Bernd,

You’re correct. Unify allows loading Midi Effects, Instruments and Aux Effects. I’m loading it as a Midi Effect (brown color) which then drives Spitfire’s BBCSO instrument.

Shane’s post in the Unify forum provided a solution to load the VST version of Scaler2 in the Midi Effects slot. It works now, and matches your screenshot of the Felt Piano, but doesn’t transmit the Felt Piano sound. Just the midi out now as intended feeding into BBCSO. So, it appears the issue may be AU specific.


1 Like