Scaler 2.3.0 Crashes in Plug In Guru Unify

If you use 3+ instances of Scaler 2.3.0 in Unify, it force closes the DAW or standalone version if you delete one instance. Tried it with Ableton 11, FL Studio 20, Reaper 6.25. Using Windows 10.

Hi @tony10000

could you try with the 2.3.1 version, it might be related to one of the things we fixed.

Hi @Ed1, it’s Shane from PlugInGuru. I’m the author of the Unify plug-in/host. Email me directly if you’d like me to set you up with a NFR license for Unify for your testing. BTW I tested with v2.1.2 and then again with v2.3.1 and could not reproduce this, so with any luck you might have got it already. Best wishes, -shane


Where can I find 2.3.1? Latest version on Plug In Boutique is 2.3.0.

Search for Scaler 2 page on and download the trial version instead of going into your account.

There’s an issue at the moment and the plugin does not appear for users who purchased the update from Scaler 1 to Scaler 2 :confused:

The full version will unlock once installed as you already have a license.

Downloading the 2.3.1 Trial now from PIB. I believe I can activate it.

@getdunne @Ed1

2.3.1 fixed it. Thanks…that is a wrap!