Scaler 2.5 crashing Cubase 11 on Mac

This is a new problem. I have been working with this session for weeks with little problem. Today I cannot open Scaler in Cubase without a crash. If I import this track into a new session, as soon as I open Scaler it crashes.

  1. What were you trying to do?

Open Scaler to edit session in Cubase 11.

  1. What do you think should have happened?

Click to open Scaler and proceed to edit pads for chord changes.

  1. What happened instead?

Cubase instantly crashed when I opened scaler. If I can get Scaler open it crashes Cubase as soon as I click on a pad.

  1. What system/software do you use?

Using macOS 10.13.7 (High Sierra) and Scaler 2.5, Cubase 11.0.30

Another question to ask… (the 5th number 1. question :wink:

“What changed?” - if this used to work just fine. What is different with this scenario?

Hi @jamieh

would you mind sending the crash log?

You can find it in the MacOS “Console” application:


Nothing that I can think of. I had just had it open to Drag and Drop the set of Patterns to a track without the performance which worked fine. Played with that for awhile - Closed session. Reopened the Cubase session and went to turn the performance back on - Open Scaler - clicked on a Pad - Crash. Continues to crash just opening scaler in Cubase now. Scaler itself opens fine. I don’t have that XML saved so I can’t open that. The session XML leading up to that seem fine.

I can send a Cubase session with just that track if someone want to try opening it. I would love to see if the XML can be saved and reopened by me.

Here is a link to the crash log and a Cubase session with the track.
Crash Test

everything is good in studio one

Hi @jamieh and thanks for your time,

We have been able to open up the Cubase project you send us.
Tested on Cubase AI (version Cubase 11.0.40 Build 446) on macOS Big Sur (11.6.1 Intel) with Scaler 2.5.0 VST3 version.
We have been able to browse patterns, play chords (click and bind) and DAW playback in sync, drag and drop to tracks etc.
We unfortunately haven’t been able to replicate any crash yet.

Do you have any additional information that could help replicate the issue you are facing?

Could you please tell us what are your ScalerSettings?

Have you tried to restore those settings to default? (saving them first if you wish)

Thank you,

1 Like

My panels don’t look like those. What version is that. These are mine. Nothing strange. And just t be clear the crash is mainly due to that Scaler session I sent. I cannot open it even in a single track of Cubase. I can open Scale in that same Cubase session if it’s blank or any other if I load an XML into another Scaler.

I’d love if someone export the whole Scaler session for me so I can see if it will import any differently. The good thing in all of this is I have a much better set of chords now so maybe Scaler is rejecting my chord choice. :thinking: :grinning:

A preview of 2.6, perhaps ? :slight_smile:

Hi @jamieh ,

Those Panels are coming from the ScalerSettings companion app (@yorkeman this isn’t a preview of 2.6 sorry :slight_smile: ) that is installed aside from the plugins. You can try to reset those settings from the Help panel.

Does this suits your needs: Scaler-State_2021-12-02_125706.xml (50.0 KB)


Thanks for this. I imported this session and it behaves just fine. The one I sent you still crashes so maybe it was corrupted on my setup. Thanks again.

1 Like