Scaler 2.5 is not shown as VST in Ableton 11

Hey everyone,
I’ve been trying to use Scaler as a VST instrument in Ableton 11 for days. I have it installed but it only shows me the AU version. So I’m not able to route midi to other instruments. Does anyone have the same problem or even better a solution for it?
Here are my specifications.

Mac OS Monterey
MacBook Pro (14", 2021)
Apple M1 Max
Ableton 11.1
Scaler 2.5

Thanks!

1 Like

maybe because Ableton doesn’t find the VST in its standard & custom folders?
I found that many plugins tend to install in not standard folders

1 Like

The vst is installed in the correct folder. I also tried to create a user folder and move the scaler.vst file there. The AU version works fine, but neither vst2 nor vst3 are recognized after the scan.

This might provide some info.
Note: When used on an Apple Silicon computer, the Universal build of Live 11.1 only recognises VST2 and VST3 plug-ins natively compiled for Apple Silicon. Please note that some specific AU involve Intel-compiled processes, and that these will require Live to be run as an intel application via Rosetta 2. You can find more information here.

so that means scaler 2.5 is not available natively compiled for Apple silicon?

tried out a few different versions of Ableton.

Ableton 10 (intel) - scaler is working as vst2 and vst3
Ableton 11 (intel) - scaler is shown in my vst2 and vst3 folder, but I can’t open it.

btw the demo version of scaler 1 is working as a vst in Ableton 11.

Have you tried running Ableton Live 11.1 under Rosetta? That works for Logic and other plugins.

Yes, I already tried that. Same problem :frowning:

can any of the developers give info if there will be an update on this issue? Would love to use Scaler as a midi trigger in Ableton 11.

What is your setup? I use Scaler in 11.1 all the time and it works great.
Mac OS 10.13.6 Ableton Live 11.1

Mac OS Monterey 12.1
MacBook Pro (14", 2021)
Apple M1 Max
Ableton 11.1
Scaler 2.5

I’ve really tried everything possible. Does anyone have another idea?

Hi @julian1

Are the plugin installed in the default location?

Live 11 can see the VST and VST3 on my M1 (not PRO) machine.
I installed Scaler in the default location and used the system folder in the Ableton Live Settings.


Not too sure what you can try next. Maybe remove any copy of the plugin you have on disk, make sure to install them in the system folder and try to re-scan in Ableton Live.

Do you have another DAW to check if the VST or VST3 are detected?

Hi Ed, thank you.

The plugin is installed in the default location. All plugins are in the right system folders.
I tried to uninstall everything - also the Scaler 1 demo version. Nothing changed. Still have the same problem after reinstalling and rebooting.
I also tried to copy the VSTs to the custom folder and rescanned all plugins multiple times.

I don’t have another DAW. Just different versions of Ableton Live. Ableton 10 (intel) works great with Scaler 2.5 VST.

Have you tried performing a deep rescan (Opt + Rescan) ? Otherwise you can try and delete the Preferences.cfg file from User>Library>Preferences>Ableton>Live 11.0 and set up everything again in Live
If all else fails, that is reset Live.

Also see this re VST’s not showing up in Live 11:

For myself, it turns out that the Universal Build of Ableton doesn’t work with plugins that weren’t built for Silicon (any Mac with an M1 chip in it).

Either switching over to force the Universal build into Rosetta mode or simply using the Intel build of Ableton brings the VST’s back.

Thanks Davide.

I already tried the deep rescan, but nothing changed. Still the same problem. Deleting the preferences.cfg hasn’t helped either.

Isn’t scaler built for Silicon?

Hi Julian did you try opening in Rosetta and scanning there to see whether that scans correctly as a process of elimination?

  1. Find and select the Live icon in your Applications folder.
  2. Press Command – I, or right-click / access the File menu, and select “Get Info.”
  3. In the Info window that opens, check the box for “Open using Rosetta.”
  4. Close the Info window and re-launch Live.

Yes, Ableton is opened in Rosetta Mode.

Ableton announced a new update, yesterday. Maybe this will fix the problem.

I just updated to Ableton 11.1.5 and this solved the problem! Now I can open Scaler 2 as VST3. VST2 is still not working, but that’s ok.

Thank you all for your help!

1 Like