Scaler 2.5 Logic 10.7.1 macOS Monterey MIDI FX Stuck Ghost Note UNUSABLE!

2.5 is completely unusable right now in Logic 10.7.1 on Monterey. When you start playback in Logic a ghost note is triggered and gets stuck. Every single time. Do you guys test this thing before you release it?!

Logic has been having problems with 3rd party MIDI FX since the 10.7.1 update. This may or may not be connected with that. Can you run it under Rosetta on Monterey?

I am not using Rosetta. So you are blaming this on Logic? If it’s indeed a Logic issue then it needs to be reported to the Logic team and this would be the job of the Scaler developers who have a direct line to them.

You should read this thread as I feel it is related. Problem with 3rd Party MIDI FX Logic 10.7.1

Yea it’s definitely a logic issue since 10.7. Not just Affecting Scaler. It’s also best if we all report it via Apple feedback. They’ll fix it quicker if they see it’s more widespread.

2 Likes

I will be reporting it.

1 Like

I’m using Scaler 2.5 in Logic 10.7.1 Monterey 12.0.1…

the Midi FX version of Scaler is not producing any sound on my instrument! please fix this.

Welcome to the forum @beatsbylerner MIDI FX is broken in Logic 10.7 using Monterey on M1 Mac’s. This is not a Scaler issue but an apple issue and affects all MIDI FX. Please report to Apple and let’s be hopeful of a fix in a new Logic update. We don’t advise or support Monterey at this stage as per many plugin manufacturers.

You do realize anyone buying a new M1 MBP has no choice but to run Monterey…?

Thanks Jonah, as an owner of over 40 Macs I would not purchase any M1 based Monterey for my audio needs until Apple fixes the pass through issues of MIDI FX. It’s unfortunate but common knowledge and nothing to do with Scaler. It has been reported to Apple and we are all hopeful of a fix soon. You can install Big Sur if you need or just avoid MIDI FX for now.

As a former Apple engineer, I’m here to inform people that it is impossible to install Big Sur on any M1 Mac that didn’t ship with it and shipped with Monterey. There is no rolling back. I’m sure you already knew this since you’re such a Mac aficionado. :wink:

I didn’t have any issues rolling back an iMac 24" M1 to Big Sur.

That’s because your machine shipped with Big Sur. Go re-read what I wrote. The new MacBook Pro machines do NOT ship with Big Sur. They ship with Monterey.

If you have access to a backup of Logic 10.6.3, it should work in that version.

Also it’s not an M1 issue. I had the exact same behaviour on my Intel. It seems to be dependant on the Logic version.

Edit: I think I replied to the wrong person, but I can’t remember who I meant to reply to, so, whatevs :slight_smile: