Scaler 2.7.3 slow loading on Reaper

I upgraded from Scaler 2.5 to 2.7.3 at the weekend ready for the course which I have now purchased. I notice the latest version is much slower to load and navigate than version 2.5. For reference, I am using Reaper which is generally very quick compared with most DAWS. Is there a reason for this and will it be fixed at some point? Thanks.

Which version of Reaper are you using, and what is your OS?

I haven’t noticed much difference from other versions of Scaler, nor from loading other vsti synths.

On my system (Windows 10 22H2, Reaper 6.79) the load time seems to be about 3-5 seconds. Obviously this depends on a number of factors, but I wonder if you have benchmarked it against other instruments to see if it is a Scaler issue or a Reaper issue.

Reaper 6.78
OS - W7
PC - i5 2500/16GB RAM/2xSSD
Load time for Scaler 2 instance - 15 seconds

Time taken to arm the record button - 7 seconds
Scaler 2.5 was roughly half the time on the above

Benchmark comparison load time for one instance
Omnisphere/Trilian - 4 seconds
Kontakt 6 Platform - 1 second (Libraries vary from 1-4 seconds)
EZdrummer - 3 seconds
Spitfire Originals - 7 seconds

Hope this helps

Kind regards


Vital load time - 1 second
Izotope IRIS - 6 seconds
VSL Vienna Synchron Player - 11 seconds

Just tried on my m/c … I hadn’t noticed 2.7 being any slower. I can’t really tell if any of them were 0.7 seconds or not, so 1 second is the smallest number.

Scaler 2.7 - 1 second
Omnisphere - 1 second
Kontakt 7 player - 1 second
Ozone 10 - a bit more than 1 second.

I would have expected Omnisphere to be slower. Ozone 10 is a massive memory and CPU hog and the first load was about 6 seconds - see below.]

I noted that if you do the tests more than once, the times vary, normally getting quicker. Checking out Task Manager, I think some of the time is spent memory grabbing by the host, so if it has already got a chunk allocated, the second load is quicker.

Box is i9 - 9900 / 32 GB / Samsung EVO 970 M2, so that accounts for the slightly quicker loads on my machine.

Without using a stopwatch a selection of my instruments (including Scaler) all seem to take the same amount of time to load: 2 - 5 seconds. From my perspective this is not unreasonable as I am using a laptop with 500GB SSD and 1TB HDD (my vsts are all on the SSD), !^GB RAM and i7-10750H CPU @ 2.60GHz . It is not fast, but nor is it slow.

Both Cakewalk and Live 11 seem to also take the same amount of time.

I am wondering, @MartinJG, if there is something running in the background that could be slowing things down. I am not a techie so I don’t really know what this could be, but do you have AV that is checking each app every time you load it?


Thanks for your feedback. You have a powerful PC so I would expect your times to be much faster but in my case, I have to go by relative performance and something is definitely not right. You are right about the second load. See my further thoughts and info on my reply to ed66.

ed66. I checked the ‘processes’ Task Manager. Could MsMpEng.exe - Antimalware Service Executable be the possible cause? Something is definitely not right. I am also having problems with my midi keyboard connection. When I load up an instance my keyboard does not fire up with no signal received. If I close Reaper and then reload another instance I then get a connection and the midi signal is received. Just bizarre. I thought it might be a poor USB connection but I now think there is some interference in the background as you suggest. For reference, I also loaded an instance of Spitfire BBCSO Core. It took 5.02 mins to load. LABS takes 1.35 mins. Not kidding. They are renowned for being slow loaders but not that slow. What is odd is that some of my plugins do not appear to be badly affected. If you have any ideas, please let me know.

Edit to load time on BBCSO. I did a fresh download/installation at the weekend. I just checked the library folder. It included versions 1.18 &1.19 as well as the current 1.5 so I deleted the older versions and the load time has fallen to 1.11 mins.

I deleted Scaler 2.7.3 and re installed 2.5. The load time is 5 seconds without any sign of latency. Arming the record button is instantaneous as is navigating around the programme. I can only conclude that there is a problem with 2.7.3 on my setup ( W7/Reaper 6.78 ). I can also confirm that Reaper is back to its snappy performance. Could the developers kindly let me know if there is a fix as I want to use the course that I purchased at the weekend and which I believe incorporates the latest version of Scaler 2. Thanks.

I get the feeling that there is something anomalous about that Scaler load time vs, say, Omnisphere, a heavyweight multi-timbral synth. {I have the nylon Sky extensions where some patches are Gb in size …)

Windows background tasks are notorious for choking CPU timeslices on audio machines.
Disable background virus scans, antimalware scans, and Search Indexing in Services or the MSConfig startup menu. Or just stop the processes in Task Manager, but note that they will automatically restart when Win senses a need to use them.
Also think about what network traffic is absolutely necessary when in your DAW (email, browser, etc.) and/or stop network access when mission is critical.
Scaler 2.7.3 loads by my benchmark in 3.2 seconds.

I suspect this is a W7 related problem by process of elimination. Scaler 2.5 has always been fine. Scaler 2.7 never worked and 2.7.3 has been problematic. I imagine the developers assume that everyone is now using W10 and it seems everything is fine with that OS. Thanks for your feedback.