Scaler 2.7 Multi-Out template for Ableton

Hey all,

Just experimented a bit with the MIDI routing for Scaler in the multi-output mode. Anyway, a simple template to help some people out with some channels routed to other instruments. For the simplicity I chose some random onboard Ableton instruments that can be exchanged for any of your own virtual libraries.
Took me a while to find the right routing, but this might help some people creating their own template. Do put Scaler in multi-out and choose the MIDI FX mode.Download on Dropbox


Thanks for this. This is a good template although I had to fiddle with it first to get it to work for me. All the connections were there but greyed out so I had to reset them manually. Also you have a few 3rd party plugins on the buss channels that many people won’t have. Easy enough to delete or switch to equivalents they might have though.
Good job! Solves many issues in the Mac side. I don’t know if there is an equivalent on the Windows side.

Yes people can just delete the sends or add their own when making a template. Added some standard Ableton instruments, but wasn’t really thinking about changing those in the send channels :smiley:
Oh and I should mention, a template made for the latest Ableton 11 version.

How do i choose MIDI FX Mode? @KCFYX

Push “detect” then choose MIDI FX

Well…First thanks for the template but I just can’t get MPE to work on the IAC bus. I have MPE setup to multi-channel on the IAC bus but can’t get individual channels out to each midi track. On the midi tracks all channels is the only option and so I get the full chords on each midi track. There’s no way of choosing individual channels. Any ideas why? I’ve tried pretty much everything. I’m on a mac.
Screenshot 2022-11-06 at 7.34.11

Try IN and not Auto :wink:

HEY @KCFYX do you mean the “detect” button in scaler? i cant find the midi fx mode too…
the whole template it seems to work but some how i got a midi feedback loop i guess… when i press one note it plays it over and over again

Thanks did that after posting pic - still doesn’t work. Monitor in on all midi tracks is greyed out. Oh well.

Mac users should have got now that Windows is totally another beast

what works easily with Mac is a nightmare, or a Mission Impossible with Windows

and Ableton is a further pest because it hates Multi-MIDI at all: game over

I’ll publish a series of tutorials in the future about SIMPLE templates for Scaler + BBCSO, Scaler + Opus Pop Brass, and Scaler + Garritan World Instruments, but I have little time for about 1-2 weeks

works for me, even have your driver installed well?

I am so glad I never use Windows :wink:

Seems to work but I had to set the midi track to ‘all ins’ and then select the channel from 2-5 for 4 note chords. I’m getting individual notes out.

Definitely working now. Thanks. Just had to change to all ins and then select the channel number (mpe)

Why? This is an Ableton issue, not a Windows issue despite what Ableton may claim. It is not a problem on other Windows DAWs such as Reaper. I believe that here are other issues on Apple OSs (just check out the threads relating ot MAC problems on this forum). There is no perfect solution.

Should have looked at this first, it is a solution and it is free!

@vince has posted a video here.

1 Like

if it wasn’t a video…
I cannot take any advantage from videos, YUK