Scaler 2.7 with CbB Sonar


I wonder if anyone else uses 2.7.3 with Cakewalk Sonar and Win 10. I’m dealing with crackles with indicate CPU usage to the point that I have to remove Scaler while mixing. Didn’t happen with previous versions.

Is there anything I can disable in the 2.7.3 version to lower the CPU usage? And is anyone else encountering this?


check your latency settings - you should be using either the ASIO that came with your IO device, or WASAPI - prefer exclusive to get maximum performance. if you’re using ASIO4ALL or REALTEK ASIO – that can be the issue. but if your CPU is being driven hard - it’s usually multiple VI or VST running with low latency.

Thanks fossile,

I seemed to have had my buffer at 32 samples on my Komplete 6, am trying 128 and will let you know.


I have that combination, although I don’t use Cakewalk much these days (although I used it for many years prior to the switch to Ableton Live).
The factors which cause dropouts can be CPU / low memory and or swapping / audio interface latency / driver latency . I’ve never had a problem, although I have tended to have had ‘big’ machines. I’ve used MOTU audio hardware for some time, and their ASIO drivers are efficient; as above ASIO is a must, IMHO.

Buffer sizes are crucial and should be the starting point for your investigation in my view; it probably needs a bit of experimentation to get this right.

Cakewalk still comes with it’s old DXi’s and I think it’s better not to use those as they maybe don’t use hardware as well as a VST3.

asa note: i tend to keep mine at 192 or 256 samples. most VI will work nicely with that.

I can say that it wasn’t the jump to 2.7.3, it was something in the last install of CbB that changed my samples down to the lowest number possible.

Thanks guys for the help, I was pulling out what’s left of my hair!

I have worked with CbB (Cakewalk) since 1993 (PT, Cubase, & Nuendo also), and in the last three years of updates, have seen various random things in Global Preferences get ‘changed’ during an update for no discernible reason.

Don’t freak out, it is very random, very rare, and individual machine dependent, not the fault of the software.

Just try to maintain a memory of your settings if possible. I occasionally will do a library of screenshots of my CbB Preferences pages.

I’ve been advocating for a way to ‘backup & restore’ system global prefs… the bakers are contemplating it.

i periodically backup my INI files from the program and program data and roaming folders (i use a job in freefilesync so i run it before i update or after a bunch settings getting tweaked.

Good ideas, outrage and fossile, I’ll keep 'em in mind.

What a pain, my problem is that I immediately thought it was Scaler’s fault and not Cakewalk …

i think all software has issues. my backup strategy covers about 50 products where i can. the worst being Microsoft Edge updates constantly erasing my settings no matter what i do.