Scaler 2.8 Not opening GUI and VST3 Crashes Cubase Elements 11 and 12

Windows 10 Home 22H2 O.S. Build 19045.2965

Cubase Elements 11 Build - 11.0.40
Cubase Elements 12 Build - 12.0.60

Steps to Install.

Uninstalled Scaler 2.7.3 - Reboot Laptop.

Installed Scaler 2.8.0 VST2, VST3 – Essential Sounds - Reboot Laptop

Scaler Settings OpenGL is set to OFF
‘Turning it ON’ Cubase Elements creates a serious error message’

Re-Installed Scaler 2.7.3 and works fine

Hi @Studio-dbfx

it runs fine here on a Win 10 machine within Cubase Element 12 as a VST3.
Do you have any custom UI settings in Cubase that could cause an issue? Do you have anything specific in terms of resolution, any external monitor, …etc?

Hi @Ed1

Only the HiDPI is set to ON in Cubase Elements, turning it off made No difference.
Windows Scaling is also on Normal.
The other settings in Cubase Elements are default settings.
I haven’t any external monitors connected.

Hi @Ed1

After reading a post by @DanDiplo . I tried installing Scaler 2.8.0 with ALL the sounds.

Scaler 2.8.0 now works!

I usually only install the Essential Sounds, as I have a Ton of sounds already.

1 Like

Same here. I just try to open Scaler 2.8 trial version as an insert in Cubase 12.0.52 Pro and Cubase crashes. I also did a computer restart and a re-launch of Cubase but the problem persisted>
I sent an image of the error window, to and that image and a Cubase crash dump file to (Pluginboutique seems to not accept anything other than images)
I was really excited and looking forward to trying Scaler but how did this very basic problem get past testing? I mean, it doesn’t even open!
This kinda makes me lose confidence in this product and company. But believe it or not, I still really want to try it out!
Is Pluginboutique usually timely in fixing this kind of problem?

I recognise it’s frustrating when this sort of thing happens.

I’m old and wizened and have to say compared with most software vendors over the years I have dealt with {1} the Scaler folk are actually very supportive in trying to address problems (but be aware of the time differences), as are the regular visitors to the board, so hopefully you will get resolution {2} Scaler is an amazing app and top of it’s niche, so it’s worth a bit of patience.

Thanks much for this response. I’m sitting here excited to try it, and frustrated at the same time.
Good to know that they are usually good at taking care of things like this.

On the time difference: Where are they located?

Good to know that it’s a cool plugin!

Sunny Melbourne, Oz, so way ahead of GMT here in London.

BTW, you didn’t say which op system you are an, which makes a big difference to which board members chip in. If it’s the Mac, you also need to say which cpu is … seems to be a lot of issues with macs at the moment.

Here’s you go: Windows 10, Core i5, 32GB RAM, 4 internal SSD’s.

I’m still trying a number of different options and will post an update in a bit.

Thanks again for the response!

Have you tried to install ALL extra sounds?
This trick works for many others

But if you don’t need them (like me) you can wait that PB load fix

I posted my findings and a (real) solution here: