Scaler 2.81 install fails windows 10; error "windows service pack 1 required"

Previous install of Scaler 2.7 installed/ran with no problems. 2.81 install fails immediately: “This program requires windows service pack 1 or later”. My current Windows 10 OS build is 19045.3324

Hi @TerryV

Just to clarify your Windows build, I think the number you have quoted

may refer to the Feature and Experience Pack. Are you on Windows 10 22H2?

Scaler works fine on my win 10 Pro10.0.19045. What happens when you ‘check for updates’? The above version says I’m up to date as of now.

1 Like

I’m on Windows 10 Home edition, version 22H2, OS build 19045.3448, with Windows Feature Experience Pack 1000.19044.1000.0, Per Windows Settings>System>about: Had an update last night, hence new OS build number… No effect on symptoms, however.

Hello and thanks for your interest. Checking for updates shows 2 optional updates available: .NET framework, and 2023-10 Cumulative Update. Installing/running these updates now… I’ll advise status after these run… Thanks!

Updates completed and no other updates available. Latest system specifications are:
Version 22H2
OS build 19045.3570
Experience Pack 1000.19052.1000.0
Symptom is same, errmsg right after language selection (English) on install of Scaler 2.8.1.exe
I also tried running as admin, no change.

Have you tried downloading Scaler again and installing from the new download? I ask because I have the same OS spec and have not experienced any issues with the installation of 2,8,1.

Another approach would be uninstalling your current version of Scaler and then trying to install 2.8.1 from a new download.

If this does not work may I suggest turning off any antivirus you are running during the installation as this may be blocking the installation.

This is identical to my configuration and I too have no issues installing the latest version of Scaler - 2.8.1

Tried uninstalling the existing Scaler 2.7, download/install fresh copy of 2.8.1, same error persists. I also had Norton disabled while this was going on. !! Isn’t it the case that since I’m runnning on Windows 10, there technically is no longer any such thing as “service pack 1”, as service packs, per se, are no longer part of the lexicon in Windows10?.

I think you are correct Service Pack 1 was released for Windows 7. Windows 10 does not have Service packs.

Have you searched the internet for solutions to this issue?

Like the old song…“I been searchin…every which way…”
I tried one “fix” proposed at which makes a change to the registry. Had no effect, so I changed back original. Plus, this video actually was a Windows 7 pc, not Windows 10. Need developers maybe to look at this and see what sequence of events is triggering a “canned” response as part of some handshaking or interaction with an external process. ??

I was curious about this so I had a quick Google, and there is an another example of this which was solved by running the installer in compatibility mode (It was for a Spitfire Audio product).

A hex editor search on the 2.8.1. installer confirms that the installer does not contain the error message, but does refers to ‘service pack’, clearly some code leftover from Windows 7.

It seems like an installer problem but there is some quirk which it appears on your machine.

Anyway, see what compatibility mode does …

1 Like