Scaler 2.9 FL Studio crash

I’m having an issue when running Scaler 2.9 with FL Studio 21.2.3.4004 running on Windows 11 23H2

At various points FL Studio closes, no errors or anything, with the below being logged in event viewer.

Faulting application name: FL64.exe, version: 21.2.3.4004, time stamp: 0x65c0eb93
Faulting module name: Scaler2.vst3, version: 2.9.0.0, time stamp: 0x66281994
Exception code: 0xc0000094
Fault offset: 0x000000000052c270
Faulting process ID: 0x0x62E0
Faulting application start time: 0x0x1DAA09D87A5A5B1
Faulting application path: C:\Program Files\Image-Line\FL Studio 21\FL64.exe
Faulting module path: C:\Program Files\Common Files\VST3\Scaler2.vst3
Report ID: 691080f3-82eb-474b-a4dc-6103281d0fb6
Faulting package full name:
Faulting package-relative application ID:

The above was from the VST3 version of Scaler 2.9 but I’m seeing the same issue with the VST version too, same error code of 0xc0000094 which appears to be a divide by 0 error.

Looking at other forum posts, I’ve tried disabling OpenGL from ScalerSettings.exe and have also tried disabling ‘Smart Disable’ in FL Studio but the problem persists.

Any ideas, anyone else having the same issue?

Can happen at any point, but often after clicking on the transport controls.

Hi @dazjjackson, I wish I could be of more help however we have been unable to replicate this fault. We have Scaler 2.9 running as both VST and VST3 on Windows 11 in FL Studio 21.2.3 (4004) with no issues. The only thing I can think to recommend is a complete reinstall of Scaler 2.

We’ve had no other reports of any issues with FL Studio on Windows 11, so I wonder if there is something else causing the crash. If you can provide any further info on your scenario we can look into it further.

Hi @Tristan, I’ve just tried an uninstall / re-install of Scaler 2.9 and I’m still able to fairly easily create the behaviour - All I need is one instance of Scaler 2 and then just interact with it, add some chords, stop and start playback a few times from the FL controls, save the project and sooner or later FL Studio will just exit.

I tried raising this with Image-Line in case they had anything to add, but they were fairly short just saying the problem is the plugin.

I have just tried disabling audio detection though and since then it does seem to have stopped it from happening, I thought I tried that the other day but I had a couple of instances, so maybe only did it on one of them - I’ll give it a bit more of a test and let you know but so far so good.

Hi,

I use Scaler V. 2.9.0 with FL studio 21.2.3 on my PC running Windows 10 Pro version 22H2.
For the past few days, my FL studio sessions have stopped suddenly.
Looking in Windows Event Viewer, errors are reported in the logs. The source of these different errors is Scaler V.2.9.0.
Below is one of the error messages (in fr):

------------------ error log
Nom de l’application défaillante FL64.exe, version : 21.2.3.4004, horodatage : 0x65c0eb93
Nom du module défaillant : Scaler2.vst3, version : 2.9.0.0, horodatage : 0x66281994
Code d’exception : 0xc0000094
Décalage d’erreur : 0x000000000052c270
ID du processus défaillant : 0x2408
Heure de début de l’application défaillante : 0x01daaa2fad11c2ba
Chemin d’accès de l’application défaillante : C:\Program Files\Image-Line\FL Studio 21\FL64.exe
Chemin d’accès du module défaillant: C:\Program Files\Common Files\VST3\Scaler2.vst3
ID de rapport : 50fd13c9-6643-4e4f-bb22-ee153c8f014f
Nom complet du package défaillant :


This problem started late last week. How can we fix this problem without losing the data saved in scaler V. 2.9.0. ?

For the moment, I am looking for a practical and quick solution to return to a normal situation, because the plugin is great. However, if I can’t use my DAW because of a plugin bug. I should consider other options.

@Bob123 @dazjjackson Welcome to the forum and thanks for posting. We’ve not been able to recreate this but since there have been a few reports we have passed this on to our developers. Will let you know if we have any luck reproducing.

If this is the same bug that I’m encountering, I can consistently reproduce it by having Scaler 2* in a project, going to FL Studio Settings > MIDI, and spam the “refresh midi device” button a whole bunch of times.

Sometimes is takes a few more presses, sometimes less (it’ll happen fairly early, you probably won’t need to spam the button for more than 5 seconds or so).

Hope this helps :slight_smile:

*Scaler 2.9.0, VST2 version, midi output port = 2 (I mainly used my startup template to test it, so it’d have those settings), Windows 7, FL Studio 21.2.3

Just had a random crash. Using the latest FLS and S2. Look forward to hearing from you/the dev team.

Hi @Maximumraver thanks for the update. I have been able to reproduce the crash. It did require spamming the FL Studio MIDI refresh button about 50 times but, but there does appear to be an issue of some kind there which could be related to the other crash you’re experiencing. We’ve passed that onto the devs so we’ll see what we can figure out. Thanks again!

1 Like

That’s more than I expected :o
No problem, and thank you too! :slight_smile: