Scaler 2 and Scaler EQ both failing to authorize RTO versions

I contacted support, but it has been several days. Hopefully someone can help me here.

I have Scaler 2 and Scaler EQ both active in rent to own, but both of them are making the hissing sound like they aren’t registered. Beatport Access is running, Beatport Access Mode is activated, both subscriptions show active, and I’ve tried reinstalling everything multiple times. I can’t use the plugins I’m paying for at all.
I’m using Windows 11 Home
16 GB Ram
Ryzen 7 CPU
Asus b450m-a Motherboard
I did recently restore from a backup, but I’m pretty sure that’s before I signed up to RTO Scaler EQ.
Reaper is my main DAW, but the problem persists in all my others (Cakewalk, Mixbus, MPC Software & Element). It also happens with the Scaler EQ standalone.
I read in the Scaler manual where it said that as long as the plugin is unregistered, it will periodically create white noise. That’s definitely what is happening. Somewhere between the servers, Beatport Access, and the plugins, there is a communication failure. The plugins are clearly failing to authorize.
BPA starts with my computer, I’m signed in, RTO status is active, and Beatport Access mode is enabled.
I’d appreciate any help.

Sorry I repeated myself at the end there.

Hey @lowkeyoriginal1 Sadly Beatport Access and Rent to Own is handled by Plugin Boutique so there is not much we can do on our end. Can I suggest you search this forum for ‘Beatport Studio’ and ‘Beatport Access’ where certain users have had problems and found some solutions. Maybe that may help? Please let me know how you go with the issues, let’s hope this gets sorted quickly.

1 Like

I promise I’ll post the solution once we get it sorted. I can’t be alone in this. Every other instance in the search had to do with once the plugin was paid off. I’ll be ready for that!!! :slight_smile:

I’ve tried everything I could think of. I’m used to troubleshooting on my own. I’d bet money it’s not on my end.

We’ll get there.