Scaler 2 AU Crashing Validation (even on new-build with new hardware)

Scaler 2.8.1 (and earlier) | Mac M2 (and M1) | Ventura 13.5 (and earlier) | Logic 10.7.9 (and earlier) | Native & Rosetta modes

Hi. I’ve been through a rather fun (read: hellish) 2 months, which resulted in me getting a brand new computer and reinstalling every single piece of software from scratch in order to try and fix an issue. I’m part way through a clean install, so don’t know if it’s gone, but one thing has remained constant throughout all the bug-testing and reinstalling (and there has been a lot of that) - the only plugin that did/still regularly crashes validation in Logic, is Scaler. It always passes eventually, usually on the 2nd attempt, but surely it shouldn’t be crashing validation with such regularity?

I started noticing this a couple of versions ago, and during my investigations I came across a number of people reporting the same thing (there’s a bunch on these forums) so I know I’m not alone. I have no idea how much of an issue this is, but it seems like something that should be looked into.

@davide I thought this would be helpful to know given that I have now swapped out my entire machine for a new one (an M2 instead of an M1), and have gone through several updates of the OS, Logic and Scaler. Given that it’s still happening for some of us and given that I have done so much on this (Apple Support must have me on a banned list by now!) it may be worth bumping this up the priority list.

Hope this is useful info.

Hi @EricJames The only time I have heard of any such issue is on a Mac Studio and it appears to affect several developers. Are you on a Mac Studio? And after your M2 upgrade is the issue still occurring?

Hi @davide, ah yes that’s weird!

  • Yes, in my case both machines have been Mac Studios, although I have seen it reported here on a Mac Mini too. Most reports I’ve seen simply stated M1, so I didn’t pick up on the prevalence of it being an issue with Studio Macs.

  • Unfortunately yes, it is still occurring on the M2 and that’s what prompted me to mention it.

  • If you like, let me know which other developers have been having issues and I can check and see if I have their plugins (i.e. if those issues are solved on the M2); although saying that, at one point I had +500 plugins on the M1 (yes, yes I know!) Most are from mainstream bundles like Ozone, Arturia, UAD, Sound Toys, etc, and Scaler was the only one crashing every single time I did a rescan, and in both Rosetta Mode and Native modes.

  • I have significantly paired down the plugins now, and installed absolutely everything from scratch, and again, it just seems to be Scaler out of the ~200 I have installed.

P.S. If it would help for me to do a screenshare with your devs - to let them see it in action - let me know. I’m happy to help where I can.

No once validated it should be fine, I’m not sure of any other reports of users having to repeatedly rescan just Scaler so working through some potential issues I have some Q’s

  1. Do all instances of Scaler behave the same? See below?
  2. Have you tried deleting the components (HD/Library/Audio/Components), reinstalling Scaler and Reset and Rescan Selection?
  3. Have you tried resetting all audio units:
    1. Choose Logic Pro > Settings (or Preferences) > Plug-In Manager.
    1. Click Full Audio Unit Reset.
    1. Close Logic Pro, then reopen it. Logic Pro will rescan all installed Audio Units plug-ins.
    1. Check Logic Pro or MainStage to see if the plug-in is available.
  1. Are you opening a new Logic vanilla project (no template)? Have you tried opening Logic in Rosetta?
  2. Search for ‘scalersettings’ have you tried ‘Turn Off Open GL’ and ‘Reset to Defaults’ (see attached)?
  3. Have you imported anything from your older Macs like Logic templates/settings etc?

The final thing would be to reset all of Logic’s preferences How to Reset Logic Pro (Trash Preferences)

1. Do all instances of Scaler behave the same?
No. It’s most-often just Scaler 2 that fails. On a couple of occasions one of the others has failed at the same time - possibly ScalerAudio2 (but don’t quote me on that).

2. Have you tried deleting the components
Yes, deleting some/all components has happened a number of times as part of the bug testing process.

Just to clarify: You said ‘once validated it should be fine’ and that is usually the case (though I’m no sure it always is). It has certainly been the only plugin to fail on numerous occasions when doing rescans, but if everything else is validating or if I install more plugins (and they all validate), Scaler is fine.
However, thinking back, it’s possible that Scaler fails validation again whenever any other plugin fails validation - for example if I switch to Native mode and run a plugin that isn’t M1-compliant I think it’s possible Scaler will then fail validation. I’m not 100% certain I’ve seen this happen, but I think I might have!

3. Have you tried resetting all audio units
Yes, multiple times. I don’t have Mainstage/GarageBand on here. Several times it’s been failing with a very minimal installation (new OS, new version of Logic, both in near-vanilla states)

4. Are you opening a new Logic vanilla project (no template)? Have you tried opening Logic in Rosetta?
No template, and yes it’s happening in Rosetta too

5. Have you tried ‘Turn Off Open GL’ and ‘Reset to Defaults’
Yes. I didn’t do this on the vanilla installations, but before I started any of the reinstalls I was noticing that Scaler crashed validation each time I reset plugins

6. Have you imported anything from your older Macs like Logic templates/settings etc?
No. Even when building everything from scratch it’s been an issue. This is mainly why I raised the issue, because I am fairly sure I can discount all software and hardware issues in this case, given that i’ve been doing reinstallations and now have a brand new computer

7. The final thing would be to reset all of Logic’s preferences
Makes no difference.

OK so I think we are saying that Scaler 2 ONLY fails validation on its first attempt? That is, if you don’t reset all units and nothing else fails validation Scaler will load fine everytime? What I am trying to do is here is ensure you can use Scaler as per normal (which it sounds like once you have everything installed it will) and also try and pass on as much info to the DEVS as possible. I have seen Scaler fail validation but it would be once and usually only if I install a beta for testing without restarting the machine. That’s not unusual across most of my plugins. Its just that I have noticed noise across the apple community particularly with the Mac Studio. No one has one here for testing at this stage (that may change) although we do have Mac Pros. So it leads me to think that there is something strange with the T2 security integration in the Mac Studios although I am not a coder.

1 Like

Thanks @davide.
In terms of validation, yes that’s correct, and I very much appreciate you trying to ensure it will be usable - thank you.

In terms of the wider problem, it did appear that there was some association between using Scaler and Logic crashing, but it was tricky to pin down, and because the engineers discovered some hardware issues I ended up with a new machine.

I have been busy reinstalling absolutely everything from scratch (doing my best to limit every possible variable) so I haven’t had a chance to sit down and use Logic for an extended period yet to see if the issue still exists - and I admit to feeling almost too apprehensive! If Scaler2 does still appear to cause issues I’ll let you know. It was certainly working well enough for the first year of owning the M1. This post was intended more in the context of ‘here’s some info that may be useful’ given my fairly unique situation with regards to hardware/software.