Scaler 2 Beta 5 No MIDI Out for Ableton or Bitwig

I have another post where I described my MIDI out issue with Bitwig (both beta 1 and beta 5), but I also found that I have the same issue in Ableton (after following the tutorial guide on setup in the forum). I thought it might be a bitwig issue,but it was the same thing for Ableton Live.

To be clear, Scaler v1.8 (the last official release) works in Bitwig with exact same setup. so the only variable that is changing in my setup is that I am switching from the Scaler 1.8 version to the Scaler 2 version. Something seems to have been broken in the conversion from v1.8 to the beta version 2.

Scaler 2 is not sending MIDI out to external devices for me, and it won’t even output any sound if I try to use it by itself (using scaler’s internal sounds). The GUI works but nothing is happening.

I’ve seen some people have it working and it seems they are all on Mac. Anybody have this working on PC (Win 10 OS) with Bitwig 3. I was thinking there was something in the Scaler 2 settings but i’ve literally tried every button on the screen and adjusted all preferences and no luck. I’ve tried using mouse input and midi keyboard input and no dice.

Hopefully devs can resolve in upcoming beta versions before the full release.

Unfortunately, the team is not all that prompt in providing access to the beta for testing. I would love to provide info for you, but still waiting for an Beta invite link…

Hello @jaaypeso24

As we discuss in the other thread, it works for us in Bitwig and Ableton Live 10 on Windows.
Scaler 1 and 2 work the same way.

Did you by any chance move the VST file or sound folder into a different location ?

You haven’t requested access from what I can see, have a look here so we can generate an invite for you:

Thank you very much, that is what I was looking for.

Yes, I had moved it to a different location. But I tried to uninstall and reinstall to the original location the software installed to (then redirected my DAW to look at that location), but it didn’t fix the issue. I can get the program to show up but its still not working properly. I tried both the VST2.4 version and the VST3 version (in their original install locations) and still no luck sadly.

Great news! After 2-3 days of battling this on and off I finally have Scaler v2 beta working in Bitwig. I am using Windows 10 Pro (not home) and hadn’t updated in about 3-4 months (since the pro version lets you delay updates for months). Magically, after a a restart and an update, Scaler 2 works as it should. I did change some other things as well (its working now so i’m not touching anything) so I summarized below in case it helps someone else troubleshoot.

Its also possible that the update was completely unrelated and I needed to restart my computer after moving things around while trying to resolve the issue.

Ultimately, for me, In troubleshooting I ended up hiding (aka cut and pasting outside my DAWs plugin folder) the VST2.4 versions of the Scaler plugins and just have Bitwig find the VST3 versions. Not sure if hiding the 2.4 versions was necessary but I thought I would share what worked for me in case someone else finds themselves in a similar issue. I think I heard some people have to try doing it the other way around in the beta forum (they ended up hiding the VST3’s).

So my recommendation is (if you have similar issues to what I describe above with Scaler V2)"

  1. try the VST3 versions of the plugins instead of the VST2.4 (you may have to hide the VST2 versions from your VST plugins folder), or go into Bitwig preferences and change the setting to use the VST3 version when available. Its important to note that the VST3’s are found in one location as standard and that is C://ProgramFiles/Common Files/VST3 if your having trouble locating them.
  2. restart your computer after all the changes since that seemed to work for me.
  3. If all else fails, update your windows OS as that coincided with it starting to work magically for me. I don’t know if it was the restart or the update, so I would say try the restart first (since its low risk of course) and then update. I know some people are hesitant to update (as I am) so that’s why this is the last resort recommendation.