Scaler 2 black empty window

I just got the update and the VST window is black when opened. I was hoping this would be fixed for the release.

Any ideas.


Hi @Richard

could you try with the VST3 version and check if it is affected as well?


under NI Maschine I get a black window, too.
And REAPER is crashing when I try to load SCALER 2.
Please HELP!

It’s the same with the VST3 version. B4 worked fine, the problem started with b5.

Btw, the installer does not ask where to install the VST3 version. It took me a while to find it!

Btw2, What an absolutely f… brilliant product!

I hav this problem also. Tried both VST & VST3 in Studio One Pro latest release, Ableton Live 10, I got the GUI to display when I opened it in Tone 2’s NanoHost. So I was at least able to activate the license.

I have had similar issues with Audio Filter plugins. They have a GUI setting in their Appdata You can change the value from 1 to 0 and it fixes this. It is an opengl setting. I looked at Scaler2 and the settings file doesn’t include that option.

So any fixes for this issue would be greatly appreciated. Looking forward to digging into this plugin soon

Hi Zenatix,

I just upgraded and got the same problem. I’ve been using version 1 for a long time and I can say that it has changed the way I make music (in a good way!). Support for Scaler is very good and I would suggest that you give the devs a little time to sort this out. Scaler 2 is worth the wait.

Good luck.


could you try to:

  • Navigate to following folder:
    • C:\Users\ username \AppData\Roaming\Plugin Boutique\Scaler2
    • /Users/ username /Library/Application Support/Plugin Boutique/Scaler2
  • In the same folder open the file “Scaler2.settings” with a text editor
  • Either update or add the line:

<VALUE name="openGLRendering" val="0"/>

  • Launch Scaler 2 and check if you can see the interface


1 Like

Well I added the openGL rendering line and no luck. I tried VST64 & VST3 in Both Studio One 4 Pro 4.6.1 & Ableton Live Suite 10.1.6

Attaching specs

Screen Shot 2020-01-6 at 00-50-41

Screen Shot 2020-01-6 at 01-09-39

Thanks so Much

I did the manipulation but it doesn’t work

Thanks for reporting @Zenatix, @micorm.mus

I am making a few modifications to how we handle the rendering. Hopefully the next update should allow you to use Scaler 2.

I will update here when the patch is available.

I already tried this. Still the same.

I tested with FL Studio 20 it works well I don’t understand anything we will wait for the next update thank you for your work

Hi Ed1- I have the same problem, I run Cubase 10 in Win 7, tons of plugins, none does this, i7 with 64ram and SSD, work with huge projects like a charm, this is a strange problem, Scaler 1 is fine, I bought the upgrade, used Scaler 2.05 upgrade. Hope there is a solution, thx. Flo

Flo again, I tried again, and now it works OK with the editing, thanks.

1 Like

Hi @Richard

have you tried the latest 2.0.6 ?

OMG, 2.0.6 works :grin:

Thanks Ed and everyone for all your work. What a great product.


sorry but i downloaded and installed the update 2.0.7 but it still doesn’t work

there is always a black window

on which line to add VALUE name=“openGLRendering” val=“0”/
I will try to see if it works

I found the solution I added two lines of code that I saw above in the comment Screen Shot 2020-01-6 at 01-09-39

I added two lines of code that I saw above in the comment the third and the fourth line I have the value defaultFont at 1 and he works perfectly in ableton live I will try in Cubase and I would say if it’s ok
It’s ok for Cubase it’s perfect really i am véry happy to use it, have a nice week end

1 Like