Scaler 2 black empty window

Hi Ed1- I have the same problem, I run Cubase 10 in Win 7, tons of plugins, none does this, i7 with 64ram and SSD, work with huge projects like a charm, this is a strange problem, Scaler 1 is fine, I bought the upgrade, used Scaler 2.05 upgrade. Hope there is a solution, thx. Flo

Flo again, I tried again, and now it works OK with the editing, thanks.

1 Like

Hi @Richard

have you tried the latest 2.0.6 ?

OMG, 2.0.6 works :grin:

Thanks Ed and everyone for all your work. What a great product.


sorry but i downloaded and installed the update 2.0.7 but it still doesn’t work

there is always a black window

on which line to add VALUE name=“openGLRendering” val=“0”/
I will try to see if it works

I found the solution I added two lines of code that I saw above in the comment Screen Shot 2020-01-6 at 01-09-39

I added two lines of code that I saw above in the comment the third and the fourth line I have the value defaultFont at 1 and he works perfectly in ableton live I will try in Cubase and I would say if it’s ok
It’s ok for Cubase it’s perfect really i am véry happy to use it, have a nice week end

1 Like

Reinstall using default path + rendering and font hack solved problem for me in Studio One and Reason.


Black screen here as well. I own Scaler 1 and works as it should in Reason 10. Downloaded the trial for Scaler 2 now, and do get black screen all the time and Reason crashes. I will sit on the fence till this is fixed.

yepp, this worked :slight_smile:

1 Like

I´ve downloaded SCALER2 (2.07) and get a black screen …
Black screen and/or crash on…:
Tone2 Host
NI Maschine
Cakewalk Sonar
Ableton Live

I check Propellerhead today.
Can u help, PLEASE!


To followup- thought I was good to go with 2.05. Next day could not get it to open (black box) in Studio One after updating SO from 4.6.1 to 4.6.2.

Oddly Scaler 2.05 still opened in Reason 11, but as I couldn’t figure out how to drag MIDI from Scaler to Reason, so not much good for my purpose.

I tried again , and today Scaler 2.05 opens in Studio One 4.6.2…

I assumed I needed Scaler 2.0.7, but somehow I inadvertently changed the Windows 10 default file association for the downloaded PKG file so I can’t do anything with the download.

Anyone also with Windows 10 mind checking what your default Open-with application is for file type PKG?


Hi @mandelbrot

I think you might have downloaded the MacOS version of the installer. The windows version should be a .exe file

Same prob Cubase Pro 10, Win7 v2.07. Tried vst2 & 3, with and without “OpenGL=0”
It works fine for a while, but then shows the black window. It eventually opens, but then everything moves in ultra slow motion. Then it gets worse…and freezes Cubase…

where do i get 2.06?? i just bouugh this and it doesnt work. black box when i try and open . im in windows

I purchased Scaler 2 a couple of days ago, and I’m having the same issue. I’ve tried to open Scaler 2 in Acid Pro 9, as well as MultitrackStudio. I’m using Windows 10, and right now because of the issue I’m unable to activate.

Also, when I navigate to the Roaming folder as mentioned above, there is no Pluginboutique folder there, so I’m a little stumped. Any help would be greatly appreciated.

Oh, I have Scaler 2 v2.08

I Have a similar prob in win7 v2.09 cakewalk by bandlab
loads ok but if I minimize then bring it back I get a black screen
Also It often freezes. Has anyone found a fix for this.

I’m having the same issue with Scaler 2 in Studio One 4 & 5 on my laptop. It seems to work fine in FL Studio. It also works fine on my desktop computer.
I have tried version 2.08 and 2.09. I have tried adding the lines of code listed above, and I tried reinstalling Scaler 2 a few times and different VST folder locations. I’ve updated the bios, and drivers, etc.
I get the basic felt piano sound when I hit a key on the keyboard but there’s no GUI in the plug in window.

Here is some of the system info…

|OS Name|Microsoft Windows 10
|Version|10.0.17134 Build 17134|
|Other OS Description |Not Available|
|OS Manufacturer|Microsoft Corporation|
|System Manufacturer|Dell Inc.|
|System Model|Latitude E6420|
|System Type|x64-based PC|
|Processor|Intel(R) Core™ i7-2620M CPU @ 2.70GHz, 2701 Mhz, 2 Core(s), 4 Logical Processor(s)|
|BIOS Version/Date|Dell Inc. A25, 3/6/2018|
|Installed Physical Memory (RAM)|4.00 GB|
|Total Physical Memory|3.88 GB|
|Available Physical Memory|1.02 GB|
|Total Virtual Memory|7.05 GB|
|Available Virtual Memory|1.26 GB|

This thread is a bit old, but has anyone figured out a solution to the black screen bug?
I just got Scaler 2. Running Ver 2.1.2 on Studio One 4 windows.
I sometimes get Scaler to work the first time I open the plugin, but after that I keep getting the black screen. While trouble shooting, I discovered it I have Scaler 2 in open on a track and I disable it then enable it, I can get it to work again; however once I close scaler I get the black screen again.


you can try to disable OpenGL Rendering in Scaler and check if it solves your issue: