Scaler 2 blacked out GUI

Hi peeps.

So i just bought Scaler 2 the other day. Trying to learn & enjoy it but, there are issues getting in my way. Not particularily pleased with how this new plugin is running. Starting to have a few regrets about buying it actually.


Studio One v5.1 / Win 10 Pro / CI 1 audio interface / Oxygen 49 MKIV controller.
AMD Ryzen 7 1800x / 24GB Ram / SSD drives all round.
GeForce 1060 Ti w/3G Ram.
All drivers and software/hardware are up-to-date.

Hung note, usually F above middle C when changing MODES (right side menu). Happens every time, without fail. Note rings on and if i do anything else in the menus, the sound builds up until i have to close out a restart - MY DAW that is. Not fun.
50% of the time thus far, if a note’s not ringing on, then the interface is solid black and empty when i re-open the plugin on a track. The GUI is having trouble rendering. And it’s not just a “graphics not rendering” issue, otherwise i should still have active/clickable areas within the dead space. But there is no interaction there at all. I have to trash that copy of the plugin and start a new one; and that only helps 25% of the time. Usually, a reboot of the DAW is needed.

I really hope these get addressed guys. I avoided getting a plugin like this for years because i’m a schooled/accomplished professional musician of 40yrs. I thought, what-the-hell, might be fun to play with…so far… not really.

Thx for your time.
Mark (aka SirFunkalot)…

Hey @SirFunkalot

sorry to hear about your experience so far. It seems something weird is happening with the rendering.
Have you tried disabling OpenGL rendering in the ScalerSettings application?

  • Press the Windows key to open the search and type “ ScalerSettings
  • Go to the Help page and click “Turn OFF OpenGL”.

Then, try restarting your DAW and Scaler, and check if the issue is still happening.


Thx for your time Ed.
I don’t get any results when searching for that term i’m afraid. Scaler doesn’t store anything in the start menu so i have no way to access that control panel.

Thanks for the suggestion. I was also having the black screen problem in Cakewalk by Bandlab. I did indeed find scalersettings.exe, and under help I turned off OpenGL. Hopefully, that will solve the problem.

Have a look at this location on your disk you should find ScalerSettings.exe:

  • C:\Users\Public\Documents\Plugin Boutique\Scaler2

Oh OK thx Ed i didn’t think to look in the Public folder. Found it. I’ll let you know later if this helped.

BTW the note that sounds EVERY time i touch a menu or close a window section is actually 2 octaves above middle C, not 1.