Scaler 2 Crashing Ableton 10

So, I had scaler 2 version 2.0.9 and it worked perfectly for months. Today, it randomly stopped outputting any sound. It also would not direct midi to midi instruments properly. It stopped working entirely (it was not crashing, just not working at all after months of working). I tried reinstalling and deleting the settings file and nothing helped. After that, I tried installing the new Scaler 2 version 2.2.0. After I installed and ran it in Ableton, it caused Ableton to crash almost immediately after opening the scaler plugin. I uninstalled and reinstalled multiple times and got the same results. The only positive was that the audio and midi routing did work in the new version, but it didn’t matter since it crashed ableton almost instantly.

So both versions have completely stopped working in Ableton. Any advice?

Hi @juno106 Has this resolved itself? Are you starting a new session of Ableton with no open plugs and then opening scaler 2.2 fresh? If you are still having problems please come back with detailed system specs platform/daw/os etc

Als see this post re sample rate:

Yes I have tried restarting. I tried changing the bit rate and sample size.

The new version crashes immediately. The old one used to work and now wont output sound or midi even though it says it is receiving midi. I have no other issues in ableton with any other devices or midi. I have installed Captain Chords and it is working fine.

I have Windows 10 Home

CPU - Intel i9 9900 k
RAM - 16 GB
GPU - GTX 970

I’ve had several instances with Ableton 10/ Scaler 2.2 , whilst experimenting with the use of multi-timbral softsyth setup vs having more than one instance.

I plan to do some careful tests and try and tie it down, and I’ll report back.

Win 10 Pro
32Gb memory
EVO 970 as a cache.

Hi @juno106

Check if the sound samples are correctly installed, check your custom folder as well if you have configured one before.

The default location should be: C:\Users\Public\Documents\Plugin Boutique\Scaler2\Sounds

In regards to the crashes, you can try to disable the audio detection within Scaler to check if it improves the stability.

Let us know if this helps,

I have the sounds installed but when I open them they do this weird loading process. The folder freezes and then the folder scrolls through each line. I attached a picture of what it looks like. It does this until it reaches the end of the folder. This happens for each sound folder. The left is when it is midway through this process. The right is what is looks like after its completed. The sounds load with the file info displayed initially and then they update to show no file information. The sounds still play in windows media player after the process is over. This seems a bit weird though. I do not have this file loading issue with any other media or any other files on my PC.

I have never used audio detection within scaler, so I do not think that will help.

Make sure your public Document folder is not synced to OneDrive.

Windows might have removed the file from disk and what you are now seeing is the re-downloading from the cloud.

Check within your Windows settings what OneDrive is doing. It might help.

1 Like

Good thought but it is not syncing to the OneDrive. I never use it, but I just checked to be sure.

I did open every single sound folder because I realized that each one was doing that weird caching/loading thing. Now when I open them, they are not doing it, as if they have completed some type of loading. I decided to try scaler to see if it helped. I have successfully ran scaler and used it for about 10 minutes. Maybe allowing the folders to do that weird loading thing helped?

It appeared that they were not completely “unpacked” and opening each folder allowed them to finish some sort of process. Maybe there is some issue in the zip file extraction?

I could delete and reinstall to see if it goes through that weird loading procedure again, but I’d rather not do that if it does continue to work. I’d rather not chance it.