Scaler 2 is Now Extremely Unresponsive - Ableton 11 Suite / Mac Pro M1 Max 64GB RAM

I’ve already tried:

  • using the suggested VST3 version
  • resetting the size to default
  • Option Clicking the logo to reset

The UI is about 1-2 seconds behind user actions, which basically makes this awesome plugin useless. Sometimes there are 4-5 second lags even. It used to work flawlessly so I’m so curious what changed. The only change on my end was to upgrade to a faster Mac, but I’m curious if the plugin doesn’t support the M1 chip?

Has anyone else used Scaler 2 with an M1 Max chip and been able to get it to work fluidly somehow?

Any tips would be really appreciated.

I can upload a video of the issue if that helps.

Hi, have you tried to deselect OpenGL?
There are many posts about that

1 Like

OMG You are a life saver my friend! That fixed the issues!!

For others on a Mac

  1. CMD+SPACE search for and open “”
  2. Switch to the HELP tab
  3. Click on the “TURN OFF OPENGL” button

Please add this tip to the Scaler 2 - Troubleshooting


Happy to be useful
have fun with Scaler

1 Like