Scaler 2 logic


Ive been having trouble with logic pro x and scaler 2 since the upgrade. I tried to turn midi off. I uninstalled and installed both the app and logic. NO cigar

I cant use more than one midi with scaler

mac monterey 12.01

ive read many forums here about similar issue but mine hasnt been resolved

thank you!

Hi @blastbeat914, welcome to the forum.

This is an issue affecting the MIDI FX version. There’s a couple of things you can try:

  • Update macOS Monterey & Logic Pro to the latest version (12.3.1 and 10.7.3 respectively) and check if it improves the situation.
  • Use Logic Pro in Rosetta mode which will fix the issue.

As a workaround (and without doing any of the above), you can use “Scaler2” instead of “ScalerControl2” and drag the MIDI you need on the track.

Thank you!

I saw in another post you mention to try Rosetta. Mine shows locked for some reason but I’ll figure that out.

Thanks! I’ll keep this updated

Updating worked thank you !

1 Like

blastbeat914 whats your email?