Scaler 2 midi problem

Hi, I purchased Schaler 2 and installed it in my mac with the latest Catalina upgrade to work with the latest Logic upgrade. I installed it and my midi keyboard (korg microKey 61 Bluetooth) stop working. I have the presonus faderport 8 conected via usb cable and the microKey conected via Buetooth). I reinstalled the Bluetooth Midi Connect for Mac but the keyboard dont work. I tried conecting the keyboard via usb cable but still it doesnt work. When I press the Keys on the microKey it acts as if it where a normal typing keyboard ( it minimize the screen in logic, activates loop playng, etc.).

Please Help.


Hi @James2598

that is an interesting issue. I don’t think it relates entirely to Scaler. Have you tried with other plugins to check if they work correctly?


I did not had any problem before installing scaler 2. Before installing the plugin I finished to récord, mix and master a synth song using my microKey and the V7 collection from Arturia, thats why I know its a problem generated by the Scaler 2 plugin.

With other plugins outside of logic pro, works fine. The problem happens when using Logic.

This almost definitely has nothing to do with Scaler. As per Ed’s suggestion have you tried a different plugin within logic? You can reset all midi drivers in logic / preferences / midi
If that doesn’t work disconnect all usb, boot your mac then plug in your controller.
Failing all of that boot audio midi setup and see what’s happening there

I did a backup using time machine to restore my Mac pro, and the microKey, logic, faderport 8 and the arturia plugins worked fine, then I installed the Slate digital all access pass and the problem came back. Maybe Scaller and Slates plugins have conlicts.
Can you tell me how I can reset the midi drivers? I allready errase them them and instaled them again.
It have never had this kinds of problems with other plugins.
Im stuck.
Please help.


Also check your ‘Audio Midi Setup’

You will need to search for help on both of those issues outside of this forum

After spending almos two hours on the phone with Matt C. from apple support creative media / pro apps ( Case Number: 101099772933), and checking Logic pro X and my actual computer setup, his conclusions are:

  1. Other keyboards work fine in my user (sends midi data).
  2. Korg keyboard works fine in test user.
  3. Musical typing works fine (send midi data).
  4. If you have instructions on how to reset something I need them.

Whe reset the midi drivers.

His conclusion is that when Scaler 2 was installed, it changed something (he doesnt no what) on my user account.

So, how do I fix this problem.

This sounds like a clear midi conflict that has nothing to do with Scaler. I’ll let the DEVS answer whether it does something to your user account but as fas as I know absolutely not. It installs AU/VST/AAX and sounds to your shared folder.
The Korg Microkey has issues with midi over Bluetooth. Several conflict issues. A quick google would indicate that is your problem. Look at the last few posts here: