Scaler 2 - No response on one Mac, works fine on the other!

Strange one here.

Bought the upgrade to Scaler 2 yesterday, and went to install on the 2 machines I use, an iMac and a Macbook Pro.

The plugin works exactly as it should on the Macbook, which annoyingly, is not my main music production machine.

The plugin does not work at all on my iMac. Tested in both the latest version of Logic, and Ableton (on both machines). I’ve also loaded Scaler 1 in the same midi track in Logic to test, and that works fine. It’s only affecting V2.

When I input midi notes (via typing keyboard or midi keyboard), the plugin ‘recognises’ the input, but doesn’t translate them into chords. I can see the on-screen keyboard matching the keys I’m pressing, but no chords are triggered, and no sound output.

I’ve tried reinstalling several times now. Do I need to do a ‘full uninstall’ of the plugin perhaps? If so, can anyone suggest all the bits I need to remove? (other than the VST and Component files obvs).


You’re not alone, I have the same issue. But to add to the strangeness, I’m on Win 10 (version 1909)!

Scaler 1 works fine but Scaler 2 (2.0.2) does not respond at all to input, exactly like you just described it (not)-working on your iMac.

Tested Scaler 2 version 2.0.2 with:

Ableton Live 10 Suite version 10.1.14
Bitwig Demo version 3.0.2

Installed/uninstalled, default location / custom folder, VST2/3, restarted machine, makes no difference.

1 Like

Have you uninstalled and installed both versions? Start fresh with S2 and go from there.

Thanks for your reply. I’ve uninstalled all plugins associated with S2 (VST, VST3, Component, for both Scaler 2 and Scaler Audio 2), and reinstalled the whole thing from scratch, multiple times now, to no avail.

Is there anything I need to do beyond deleting the plugin files? Any other files that might be sitting around on my machine that might need cleaning up also?

This sounds like a sound bank installation issue. Look at users/shared/PluginBoutique/scaler and look for the sounds folder. Trash it and the scaler 1 folder. Reinstall first S2 and if working the. S1. Reboot the lot and check the folder to ensure all sounds are there. Let us know if this doesn’t help one of the guys in dev can help.


I’ve just done this, still hasn’t worked.

I then searched for literally every mention of ‘Scaler 2’ on my mac, deleted everything, then did a full re-install (splash screen appeared, had to locate license file etc), still the exact same issue.

Can this be passed on to someone in dev please?

A new version 2.0.4 is out, but there was no difference, when installing it on my desktop. Still no sound and/or MIDI output.

But then, I installed this on my laptop (Windows version 1903) and…it works?

Only thing I noticed different during install, is that after the installer finished, there was a prompt to restart the computer. There is/was no such prompt when installing Scaler 2 on the desktop, it actually just flashed by the “Installing Runtime…” part that comes last and finishes the install without it. And yes, I restarted my desktop even so, but no dice.

Also, all the sound banks are installed it seems (C:\Users\Public\Documents\Plugin Boutique\Scaler2\Sounds) and all the instruments are selectable in Scaler 2 so is this some kind of runtime installation issue?

Hi @Tdot,

does your two systems share same version of OS also ?
Is there any software installed one your iMac that could be locking those audio samples files like “anti-virus like” ?
When you locate the samples files “⁨Users⁩ ▸ ⁨Shared⁩ ▸ ⁨Plugin Boutique⁩ ▸ ⁨Scaler2⁩” can you play them correctly ?

So the issue is that it does not produce any sound ?
But chords can be detected via MIDI input in “DETECT” ?

Do the played note appear on the Keyboard in the UI in blue and the top view like this ?

What happen when you change the sound ?

Have you installed the last 2.0.4 and reboot ?

@Quanta, does the 2.0.4 + reboot have made the sounds load correctly on your side ?


Hi Paul,

It’s way easier if I show you the issue;

I had hoped sound would be included in this, but you can see the audio levels in the BG to get the idea. This is in Logic, exact same problem in Ableton.

Thank you @Tdot for the video, no worries for sound missing, I can see the problem, have you tried starting and stopping the Transport (something like pressing twice the Space bar) to “activate” (or re-activate) the midi flow in order to let your MIDI FX output MIDI to your Arturia Jup-8 V3 ?

System restart number 3 seems to have now fixed it - I can’t remember what I’d done prior to this restart, but it is now working! Thanks very much for your help!

1 Like

You’re welcome, may the creativity be with you!

I am having the same issue. Scaler 2 does not recognise any incoming MIDI. Scaler one on the same track with the same settings works fine…

Just restart the computer until it works?

Edit: Sorry, forgot to add the important details. I’m in Ableton Live 10, macOS Catalina.

@AMackie you can make sure you have the latest installer 2.0.4 close all programs, remove previous installation, install, reboot, please come back in case it is persistent.

That worked, thanks a lot!

1 Like

Remove, reinstall, reboot are all for naught here. Tried many times. Still getting the same issue that Scaler 2 doesn’t respond at all to MIDI signals.

Is there a way to manually install this 64-bit Windows Universal runtime or check if I already have it on my desktop, and why it didn’t install and prompt for a reboot, but did on my laptop, and why its working there? Or am I way off base here that assumption with the cause of the issue?

Note that it says "Scaler2 version 2.0.0 on the install wizard but it’s the latest version from (


No, 2.0.4 + remove, reinstall, reboot times 3 has not changed the issue, still no MIDI information passes into Scaler 2 at all.

The sounds can cycled through and be selected in Scaler 2, they are installed OK. Checking against my laptop, where Scaler 2 works, the files are exactly the same and installed at the same location.

I don’t know if the sounds themselves are the issue, maybe it’s some dependency is not being installed correctly.

I tried installing vc_redist.x64.exe from x64 and it update to that version, but there is no change, after reinstall and reboot of Scaler 2. Still no MIDI information is going through. Scaler 1 works perfectly.

Besides the version difference between the laptop (Scaler 2 works) and the desktop (Scaler 2 doesn’t work) is that the laptop is Windows 10 Home while the desktop is Windows 10 Pro.

@luapmartin 2.0.4 uninstalled, installed 2.0.5 and the issue persists. exactly the same behaviour as in @Tdot 's video above (but in Ableton).

As you can see in the video, the keys light up when you press the keys or play notes, when you bind MIDI to A, B or C section and there are chords there.

So some information is getting through.

But, and what’s not shown in the video, is that if you try using the DETECT tab, select SRC: MIDI and press the record button, and try playing MIDI notes or play a clip, nothing happens. It just says “WAITING FOR INPUT”.

Are the issues still present for you @Quanta ?

@luapmartin yes, as described above.