Scaler 2 No sound and midi output

Scaler-2.0.8 is not working all of the sudden. I can use 1.8 old ver ok.

Same here. Reaper 5 and 6, Windows 7 64-bit. No sound out of nowhere, with Scaler 2. Restarting did the trick. Version 2.0.9.

Did anyone get the 2.09 to work? Mine has been not functioning for almost a whole month now. No sound no nothing… 2.0.9 on FL Studio Mac

I haven’t used Scaler in a while. Now I am having the same issue apparently. Can’t seem to find any fix. I’m on Logic Pro X. Love the plugin, when it works. I even tried loading an old song where I used Scaler. Thinking that maybe I could see that I had something set incorrectly. The song plays, but the Scaler portion is just completely missing from the track.

Have you tried going back to an earlier version of Scaler to see if that works? I haven’t seen this on Mac in High Sierra or Ableton Live.

Guys this is concerning and I know the dev team are all a little befuddled. I use Scaler every day across many platforms and machines and I have never experienced this problem, I can’t seem to replicate it no matter what I do. If anyone can backtrack to anything they may have done prior to a no sound output issue that helps the devs troubleshoot. Did you adjust audio midi setup on OSX? Change sample rate? Install a Midi control software like Arturia etc?
2.1 update out September 9th at this stage and hopeful that may prevent this issue which is only happening to a few of our users.
I would be super frustrated. Sorry to those that have experienced this.

I just got on Scaler 2 for the first time in about 2 weeks. No sound for me as well. 2 weeks ago it was working great?? Old Scaler works fine, just not Scaler 2. I just uploaded latest version 2.0.9 and nothing? It opens up fine in DAW but just no sound? I am using Reaper. I am using a PC and have not installed anything new from the last time Scaler 2 was used.

Wow, did not expect to read this. Scaler 2 has been flawless for me in Reaper Win10. This puts a bit of a scare into me. But keep in mind "Scaler 2.1 coming Sep 9th. "

Same problem for me too. I just bought Scaler2 last week. Was working fine in FL Studio 20, until today. The midi inputs are coming through but just no Sound output. All other plugins are working great. I tried re-installing, but that didn’t seem to help. Unfortunately, I dont even see any support person acknowledging this as a problem and informing of a possible fix.

1 Like

I’m going to take a shot in the dark… really no idea why. But, it’s come to my mind that many programs use various other packages that need to be installed.

I would possibly take a look there first off. While it will make the code a bit larger for distribution, maybe dependencies relying on sound output can be kept internal to the program until the problem is solved.

David did try to recreate it as he stated above but could not. So it’s not something that is easily recreatable.

To any of you that have experienced this problem has updating to 2.1 solved the issue?

Just updated Scaler 2 to the 2.1.0 update and its still not playing back any audio.

1 Like

I am having the same issue in maschine. It was working until I dragged an audio loop into it for chord detection, since then it hasn’t worked. I have tried updating to 2.1 and even uninstalled and reinstalled and it still plays back no audio.

No it has not in my case.


Updated to 2.1 but same issue here, no sound.

Windows 10
Reaper 6.13

Uninstalled and installed again to a different location, no avail.
Uninstalled and installed earlier versions but no change.
I’d successfully used it on version 2.04.

I don’t know how it is relevant but after updating Windows 10 (version 1903), uninstalling 2.04 and installing 2.1 does solve the no sound problem.

I just got lucky somehow. After 2 restarts of the system. I am getting back the sound now. But if this continues, it is going to be problematic. If so many people still are having this issue, I guess at this point it is unreliable.

I have this exact problem with both Scaler 2.0.9 and 2.1. Windows 10(1903), Reaper 6.

I’m on Reaper 6 (current) with no issues with Scaler 2.0.9 or 2.1. I have a MOTU Audio Express and nothing special in terms of video drivers. But , that looks like an old Win10. I installed Win10 version 2004 on June 9 2020. Since then there have been several (many) updates. Can you update your Windows?