Scaler 2 No sound and midi output

I just got on Scaler 2 for the first time in about 2 weeks. No sound for me as well. 2 weeks ago it was working great?? Old Scaler works fine, just not Scaler 2. I just uploaded latest version 2.0.9 and nothing? It opens up fine in DAW but just no sound? I am using Reaper. I am using a PC and have not installed anything new from the last time Scaler 2 was used.

Wow, did not expect to read this. Scaler 2 has been flawless for me in Reaper Win10. This puts a bit of a scare into me. But keep in mind "Scaler 2.1 coming Sep 9th. "

Same problem for me too. I just bought Scaler2 last week. Was working fine in FL Studio 20, until today. The midi inputs are coming through but just no Sound output. All other plugins are working great. I tried re-installing, but that didn’t seem to help. Unfortunately, I dont even see any support person acknowledging this as a problem and informing of a possible fix.

I’m going to take a shot in the dark… really no idea why. But, it’s come to my mind that many programs use various other packages that need to be installed.

I would possibly take a look there first off. While it will make the code a bit larger for distribution, maybe dependencies relying on sound output can be kept internal to the program until the problem is solved.

David did try to recreate it as he stated above but could not. So it’s not something that is easily recreatable.

To any of you that have experienced this problem has updating to 2.1 solved the issue?

Just updated Scaler 2 to the 2.1.0 update and its still not playing back any audio.

1 Like

I am having the same issue in maschine. It was working until I dragged an audio loop into it for chord detection, since then it hasn’t worked. I have tried updating to 2.1 and even uninstalled and reinstalled and it still plays back no audio.

No it has not in my case.


Updated to 2.1 but same issue here, no sound.

Windows 10
Reaper 6.13

Uninstalled and installed again to a different location, no avail.
Uninstalled and installed earlier versions but no change.
I’d successfully used it on version 2.04.

I don’t know how it is relevant but after updating Windows 10 (version 1903), uninstalling 2.04 and installing 2.1 does solve the no sound problem.

I just got lucky somehow. After 2 restarts of the system. I am getting back the sound now. But if this continues, it is going to be problematic. If so many people still are having this issue, I guess at this point it is unreliable.

I have this exact problem with both Scaler 2.0.9 and 2.1. Windows 10(1903), Reaper 6.

I’m on Reaper 6 (current) with no issues with Scaler 2.0.9 or 2.1. I have a MOTU Audio Express and nothing special in terms of video drivers. But , that looks like an old Win10. I installed Win10 version 2004 on June 9 2020. Since then there have been several (many) updates. Can you update your Windows?

Hello, MusicStudent. Answering your question, no I am not going to update my Windows to 2004 in the near future. I am still receiving 1903 updates though.
Scaler 2.0.9 worked fine for me until it stopped a few hours ago and updating to 2.1 didn’t help.

Got ya. So I have one more crazy suggestion to troubleshoot if you care to. There is a free Standalone wrapper [nanohost] which will run Scaler without the DAW. Wonder if this is fully functional for you? That is what I would do. The standalone uses difference audio drivers (MME versus the Motu ASIO) on my system, so I use this as troubleshooting at times.

By the way, hate to see all the reported issues and when I see Reaper having issues it makes me nervous.

1 Like

Thank you for your suggestion. It doesn’t produce any sound with the NanoHost either (with any output device selected).

Cool product with some great features!

I also have this issue on Windows 10, Reaper 6, scaler 2.1.

I had been using a registered Scaler 2 for a couple of days, then the no sound issue occurred. In my case I think it occurred after saving a chord-set though this may not be relevant.

With Scaler enabled on a reaper track, and another 3rd party instrument next in the track fx chain, there is no sound from Scaler, and midi is not passed through to the 3rd party instrument. On disabling Scaler the 3rd party instrument works, suggesting the midi routing to the track is not the issue. Restarting reaper does not resolve the issue, even when creating a new Reaper project with Scaler.

I have yet to do a windows reboot, but will try this sometime soon and report back.

It did make me wonder whether there is some code being executed that might be related to scalers access control disabling the midi output.

I have a long history with Reaper and have had great success with Scaler. But I can’t image any cause for what you describe that would be due to Scaler. Only thing I can think of is it is a driver problem. When Scaler goes silent in Reaper, does all other sound stop in Reaper? If so, that is a driver problem, possibly unrelated to Scaler, which is generally fixed by reloading or repairing the audio drivers. A long shot I know. But otherwise, I am still suspicious of Win10 and the multiple versions and frequent updates.

After rebooting Windows, the Scaler midi output on my system is ok again.

1 Like