Scaler 2 Not Sending Chord Data To VST

I’m having a huge issue when working with scaler 2 for some reason when I configure Scaler to trigger a VST it only sends the note of the key that I triggered on my MIDI keyboard not the chord that’s triggered in the Scaler2 VST would greatly appreciate why I’ve been having this issue


Do you have Key binding activated? It’s the button on the right of each of the sections. If on it will be green.

Do you have this button active? The one with the red circle…

Jinx! :slight_smile:

Yes as you can see it’s activated however when I press a key on my MIDI Keyboard it triggers the chord on Scaler2 but I don’t hear the actual chord being played on the VST just the single note that’s played from the midi keyboard not the actual chord

How does your routing within Ableton look like? I couldn’t read the details in your screenshot above.

If that 2nd slot is where Scaler is routed to, it should look like this —

Yours is missing the Scaler connection where it says PostFX —

@Chase16, on the 2nd channel set “Scaler 2” where you have ‘Post FX’ now.
Screen Shot 2021-08-03 at 11.14.03 PM

That’s the issue I’m having for some strange reason it doesn’t give me that option I only get the option for post Fx and Pre FX why don’t I have the option to select scaler2?

To me it looks like you have using the AU version. It won’t give you the option. You should be using the VST version.
The AU version says Scaler 2 and the VST version says Scaler2 without the space between r and 2.
You’ll have much better results. The AU version doesn’t really do all that is needed (as you found out) because the AU spec doesn’t have it built in. (So there’s nothing the Devs can do to fix that. It’s the way the AU plugin spec is.)