Scaler 2 sends no MIDI from my iPad Pro

This is a weird one, or so it seems to me. I had it working just fine about a week ago, but now it’s only working in part. What I’m trying to do is use Scaler 2 on my iPad Pro to receive and send MIDI data from/to my computer and external synths and such over my Wi-Fi network. Here are the facts:

  1. I am running Windows 10 Pro x64 on the computer.
  2. I have rtpMIDI set up correctly with a working session. I know this is the case because I can use the MIDI Wrench app on the iPad Pro to send and receive MIDI data just fine.
  3. I also can see that receiving MIDI data is working fine in Scaler 2 because I can play a few notes on my keyboard (which is plugged into my PC via USB); and said notes are clearly sent to Scaler 2 just fine. The detect feature, for example, will give me great chord pads as I play.
  4. But for some reason, tapping the keyboard graphic in Scaler 2 or tapping any of the chord pads in Scaler 2 does not send any MIDI data at all.

In short, this makes no sense to me and is driving me nuts. I have verified that Scaler 2 is configured to use MIDI channel 1, but every MIDI monitor I throw up on the computer shows zero data sent when using Scaler 2 but absolutely shows data from other apps on the same iPad Pro using the same rtpMIDI session.

Can anyone tell me what I might be doing wrong or need to change? I’ve already tried uninstalling and reinstalling Scaler 2 altogether several times, but it has made no difference.

Welcome to the forum @Phileosophos - tough one to point down. Have you tried playing around with the MIDI output / Input settings? Easiest way is to go to DETECT mode (you may need to hit the record button or the three dots) and assign input / output midi sources there including Bluetooth ones if relevant.

Aha! I wasn’t even aware any of that was there. It seems to be hidden under a Bluetooth menu on the iPad Pro, and I had no idea there would be MIDI routing under there. I don’t think I’d ever looked at it because I’m not using Bluetooth. But once I enabled “Network Session 1” on the output box, it all works. Thanks!

1 Like