Scaler crashing Logic

Logic 10.6.0, Scaler 2.2, Mac Mini-Catalina. Logic is crashing with Scaler and Scaler Control present. Variety of circumstances, pressing spacebar, selecting new menu items in Scaler, selecting chord edit. Anyone else with the same issues? …and any possible solutions? Thanks.

@chrissm Welcome to the forum, that’s my setup and no issue at all here. As a first point try restarting your Mac, reinstalling scaler 2.2 and restarting again. Failing that I would guess some form of conflict with another plug. Make sure you are opening a new session. Have you tried both Midi FX and Instrument. Come back if all of that doesn’t work and maybe some of the devs may have a better suggestion.

Hi @davide,

thanks for your response, but I’ve too the same issue tested on macbook pro, Imac pro and a Hackintosh.
Using booth Midi FX or Inst, Logic unexpectedly quit.
Tried to reinstall, and got the same issue.
Happened also with daw stopped and just browsing presets.
Hope to hear from you soon, and best wishes!

Logic 10.4.6
Mac OSX 10.13.6

Thanks Davide - Have followed your advice - so far so good, but may need to test it on my main template which is plug-in-heavy. All the best.

Hi, still getting frequent crashes in Logic as specified above. Have loaded new clean sessions with only Scaler present and still getting crashes when clicking a wide range of menu items. I have a text copy of the crash report if that would help?

Hi, Can anyone help? I continue to have Scaler crashing Logic (see above) - and it is becoming unusable. I dont think it is a Logic problem - I ve been running projects for days without Scaler - no problems. I have tried reinstalling, changing sample rates etc etc but if anything its getting worse. Oddly it seems to be about the 8th menu or item selection in Scaler that causes the crash.

ANY advice greatly appreciated!


Hi @chrissm

sorry to hear about the ongoing issue.

You could try to disable the OpenGL rendering and see if it improves:

You can disable OpenGLRendering from the ScalerSettings application.

  • MacOS:
    • Press CMD+Space to open the Spotlight Search and type “ ScalerSettings
    • Go to the Help page and click “Turn OFF OpenGL”:

Also, would you mind sending me the crash log next time it happens?


Thanks Ed
Please find attached crash report - clean new session, Scaler Control driving EZKeys, no other plugs or tracks. crashed Logic when I hit the midi panic button.

(first page only)

I will now try your OpenGL suggestion



I know you are looking at the issue of Scaler crashing Logic - and you have suggested you have identified the problem. Since sending you the crash reports I have upgraded OS to 10.15.7, Logic from 10.6.0 to 10.6.1 and deleted and re-downloaded Scaler 2.2. Result… no crashes so far ! Dont know if this is any help but thought I would let you know. Cheers.

Hi I have an issue with crashing all the time moving files over and adagio files I’m using Logic Pro x with all the newest updates. The Logic Pro is still on trail version but from what I have read it should be able to still work.

Hi @Markt and welcome,

would you mind sharing a bit more info on your system? Hardware, CPU, OS Version…


Yea it’s Apple Mac book air m1 8gb ram says logic has stoped because of plug-in Mac OS big surge

Have you tried running Logic Pro under Rosetta?

Scaler is more stable in this mode for now:

That seems to do the trick why is that ?

No it’s still crashing

Hey @Markt

Just some incompatibility with the new M1 architecture. There is a fix for this in the next update.

Any specific scenario to reproduce the crash?
Do you have a crash-log you can share?