Scaler crashing Logic

Hi @chrissm

sorry to hear about the ongoing issue.

You could try to disable the OpenGL rendering and see if it improves:

You can disable OpenGLRendering from the ScalerSettings application.

  • MacOS:
    • Press CMD+Space to open the Spotlight Search and type “ ScalerSettings
    • Go to the Help page and click “Turn OFF OpenGL”:

Also, would you mind sending me the crash log next time it happens?