Scaler crashing Magix ACID Pro 10 Suite

Downloaded demo version - ran .exe file to install. VST3 showed up in ACID. As soon as you change an instrument for the third time (either in pulldown or using right/left arrows on interface), ACID hard crashes. Running ACID on Win7, HP Z800 dual quad processor, 48GB RAM. On second day of demo trial - just learning my way around, but changing a virtual instrument should not cause a crash. Thanks for any help you can give. I’d love to purchase the product! Great otherwise, but unstable.

Welcome @jowry ! It’s disappointing that you have had problem, and when Melbourne (home of @davide, who, along with his colleagues have led the development of Scaler). comes on line, I’m sure they will comment.

I’d note that I have never had Scaler crash yet, and have found it to be pretty robust running in a variety of hosts. Your issue thus points to the interface between Scaler and the host, or possibly even to Win 7. {@davide, I have a Win 7 machine here I could try it out on if you don’t have one}. I’d also note that it sometimes turns out to be an issue with host updates, as happened recently.

Anyway, don’t give up on Scaler. It’s different from most applications in this space because it’s not a push button ‘play-a-tune’ thing and it maybe will expand your musical horizon in an enjoyable way. In addition, it has hidden depths as people keep on discovering new ways to use it.

Thanks @yorkeman We don’t have a Win 7 test machine so not sure we could help @jowry but if you can or any other users can help that would be great. Obviously MS dropped support for Win7 two years ago so I’m not sure I would expect the Devs to support Win7 either.

Thanks for your quick responses. I’m tied to Win7 for a while, since the Adobe CS6 Master Collection is my go to graphics software suite, and the success of running it on Win10 is patchy. That said, I am running the latest version of ACID Pro10 Suite, along with a pretty long list of VST2 and VST3 plugins (Spitfire LABS and Orchestra among them), and this is the first plugin which has ever caused ACID to crash. I was hoping to try the VST2 version of Scaler, but the demo does the install to my C:/ drive automatically, and there only seems to be the VST3 there.

I just had a little bit of luck in running Scaler 2.5 a while ago. I was able to run it in ACID, and succeeded in getting some of the other instruments to load via the pulldown menu. It crashed ACID after the fourth instrument this time. All of the other functions I’ve tried so for (as I go through the tutorials) seem to be working just fine. This is really odd. As I have said, I have no problems whatsoever, and have never even had ACID crash. I’m using Independence, Ample Guitar Martin acoustic, Alchemy, and the VITA suite which comes with ACID, and none have had so much as a hiccup (some of them have been developed well after Win7 was getting close to the dustbin. Anyway, it’s nice to see the quick responses here. I haven’t given up, but I also haven’t gotten Scaler to trigger my other instrument libraries, so I’ll get to that in the tutorials. Thanks!

OK I’ll l try it tomorrow (00:22 here) and I can hear Mrs Yorkeman asking what I’m doing … Not sure how the licensing will work, but presumably the demo version will suffice.

Hi @Jowry

if you can get us a crashlog from your system we might be able to do something. But it’s an older system and things might just be broken.

Maybe you could run a more recent Windows in a virtual machine and get Scaler in there without loosing your environment, but it’s not something I ever tried.

Thank you, Edouard! I will get you a crash log from ACID tomorrow morning (it’s 11:40pm ET here).

Report on Scaler in Win 7 :

I just loaded up Scaler 2.5 on my Win 7 test machine, running in demo mode. Vplayer 3 took a dive when loaded (and Avast also objected to it), so I loaded up Nanohost. This means I could only run the VST2 version of Scaler.

With this very limited test, Scaler appeared to perform as expected, so it can be concluded that “Scaler 2.5 runs as a VST2 under Win 7 when hosted as a single instance within Nanohost, and ipso facto, without interactions with other plugins.”

I’ll hang off doing more extensive tests until @Ed1 has had a deeper look. The next step would be potentially to load Cantabile (as Vplayer3 fails) and then run the VST3 version in parallel with other plugins.

Good morning! I just managed to find the ACID crash in my Win7 event viewer - here are the details:

Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: acidsuite.exe
P3: 60bdc432
P4: ucrtbase.DLL
P5: 10.0.14393.2990
P6: 5caeb96f
P7: 40000015
P8: 000000000006e01f

Attached files:
C:\Users\Joseph Bourke\AppData\Local\Temp\WER7439.tmp.WERInternalMetadata.xml
C:\Users\Joseph Bourke\AppData\Local\Temp\WER74A7.tmp.appcompat.txt
C:\Users\Joseph Bourke\AppData\Local\Temp\WER767C.tmp.hdmp
C:\Users\Joseph Bourke\AppData\Local\Temp\WER789F.tmp.mdmp

These files may be available here:
C:\Users\Joseph Bourke\AppData\Local\Microsoft\Windows\WER\ReportQueue\AppCrash_acidsuite.exe_6da1f839e755de19643e63774be7321b7a2bb_cab_1e1979e4

Analysis symbol:
Rechecking for solution: 0
Report Id: 41b95f91-7261-11ec-8602-d8d385943a3e
Report Status: 0

It seems that only the VST3 version of the demo installs from the .exe file. If I could get my hands on the VST2 version I could test it. Thanks again everyone for jumping in so quickly. I also tried moving the VST files to different locations on my system, but that made no difference. Still crashing on instrument change. I will also continue learning Scaler, so that I can figure how to use it to trigger my Spitfire and Ample Guitar libraries. When I can successfully do that, not having the built-in instruments would no longer be a problem.

I have the VST2 dll’s and could upload them to a private cloud with a one off link, which would save you doing a new install, as presumably you have a licence. However, I really need @davide or @Ed1 to ok this … guys ?

Since I have tested the VST2 on Win 7 and it functions fine, this might be a good solution.

I do NOT have a license yet. I have been trying out the demo, and ran into this problem. So please don’t send me the .dlls unless it’s ok’d by the team. If this solves the problem, I will indeed buy a license. Thanks.

Hello everyone. I am willing to purchase Scaler, with the assurance that, if it doesn’t work in ACID Pro 10 Suite, I will get my purchase refunded. I don’t know whether anyone has had a chance to look at my Win 7 log, but if there is still a possibility that there may be further information coming (and it’s the weekend), I will hold off on the purchase. Thank you again for all your help.

Hi @Jowry I did confirm that Scaler appears to run ok on my test machine (an old Win 7 box), so this points to an interaction with ACID somewhere. Were you using native drivers or an ASIO version ?

Hi Yorkeman j-

I checked my drivers, and indeed I was using the native Windows drivers. Downloaded and installed ASIO drivers. Made no difference - Scaler demo is still crashing ACID. I also turned on "allow multi-threaded virtual instruments" in the audio settings, thinking that might have some bearing on the issue. No dice, on or off! Unless I hear that the powers that be will allow me to try the VST2 before I purchase, I am leaning towards purchasing it, and maybe taking my chances. I really don't like to be a paying beta tester, though. As I said before, ACID has been rock solid thus far, and the only crash I have had in a couple of years of use of ACID has been with Scaler. ACID plays well with everything - I don't understand it. And it seems to be just the instrument patches in Scaler - nothing else has caused a crash. I am truly puzzled! Thanks for your reply.

Sorry about the formatting on that last post. I have no idea what happened. You’ll be happy to hear that I solved the problem! I was zooming with an old friend of mine who used to be an IT guy. He suggested that I reinstall the demo as an administrator. I did that, and now Scaler 2.5 seems to be working flawlessly! I will go through a couple of more days of assessment, but this changes everything. I’m guessing that maybe something got stepped on in the first install.

Sometimes the most obvious suggestions are the solution to the problem. I wish I had thought of it myself. Thank you for all of your help with this.

1 Like

Hi @Jowry

thanks for coming back and posting the solution, I am sure it will be helpful to others if they face the same kind of issue.

Thank you for all the help Edouard! I hope it will save others some time as well.

I figured I’d jump back in and continue this thread, since it’s related to Scaler 2.5 and ACID Pro (I think). I just purchased Scaler, and received the .license file. Opened ACID, created new MIDI layer, added Scaler2 VST to the layer. Open screen popped up. Lo and behold, when I click on the “register a license file”, nothing happens. Nothing at all. The link flashes a little, indicating that the click was received, but otherwise nothing! I can only use Scaler in demo mode, after having purchased it. When someone gets a chance, please weigh in on this. I had the demo mode working perfectly, and now that I own Scaler, I can’t use it! Thanks!