Scaler Daw tempo sync for live "performance" play /record

Hi folks. I always used scaler as a reference tool, but decided to see if I can use it to record something using Scaler “performances” by playing it /recording live into Daw.
I ran into a tempo issue. I am using Cakewalk as Daw. I set Scaler with use of another virtual instrument. (Halion acoustic piano). I laid out simple, looped drums for the test. Tried to trigger a performance. Everything goes well for first few seconds, than Scaler drifts away. So… I decided to do even simpler test. I muted drums and set audible metronome for Play in Daw. Triggered Scaler performance and just held it on one chord (perfmance). Scaler still drifted. Please solve it.
P.s. This has nothing to do with right clicking on Scaler play button to sync transport. This is only for live triggering performance pads.
Thank you.

I think your problem can be solved in the EDIT tab.
Look in this forum article:

Hi Blue, When you say

Do you mean Scaler gets out of time or do you mean that Scaler is not sustaining the note for as long as you would like?

As @jjfagot said you can set the duration for individual chords on the EDIT page,

Either way I suggest you consider triggering Scaler using midi clips.

Thanks for trying, I will try a few things based on suggestions.

Triggering Scaler 2 from midi clips, or your keyboard by binding the patterns, will enable you to set the chord duration in the midi clip. The chord will play for as long, or as short as the duration of the relevant note in the midi clip. So you can create complex rhythms for your chord sequence, and even vary it for a given pattern.

Hope it works for you.

Just a point to note I put a short midi clip onto Cakewalk and it did not drive Scaler. Some fiddling around showed me that teh midi clip seemed to be sending midi two octavwes lower than I expected, Transposing the mdid clip up two octaves to C4 seemed to fix this!

Here is short video from Plugin Boutique about driving instruments from Scaler in Cakewalk

Just another thought: where you are getting this drift are you using a compound time signature, or at least not 4/4? You may have to change the chord duration in the Scaler Settings. I think this can be mitigated by using midi clips and binding Scaler to the midi clip.

It seemed to work for me, but I did have to set DAW synchronisation to OFF, which seems counter-intuitive.

If you drag the midi clip generated by Scaler to its own track (or to another track that depends on Scaler) and you don’t have Scaler OFF, things sound different. Sometimes (guided by TMacD’s advice) I’ve done it to get new things, happy coincidences (which there are), but for the specific topic at the moment, it’s better to leave Off Scaler when you’ve dragged the midi.

Scaler is not a “centerpiece” of composition. I just wanted to record a few lines semi-live, triggering performances as I go on top of existing audio / Midi tracks. Daw sync is off, as I do not want it to sync to to transport.

Kontakt (session instruments) / Halion steinberg stuff syncs well for live triggering. I guess I have to play around with it some more. Some kind of latency on Scaler side, that becomes more prominent after some time, if performance is triggered and latched. I will investigate some more. If I remember it correctly, it might be jitter…

Again, for years, I used Scaler only as a reference tool :slight_smile: I guess I expected it to work “out of the box” as Kontakt or Halion. With hints you made, I should be able to pinpoint issue.

Thank you.

Solved my problem about the transposition of the midi clip. Apparently Cakewalk sets the bass octave for mid to zero as a default. ON Scaler, and many other vstis the bass octave is set to C-2.

To change this in Cakewalk


At the bottom of the screen is a scroll box labelled Bass Octave for Pitches. Set this to -2 and SAVE.

I just forgot about this as I don’t use Cakewalk often enough, but maybe I will now.