Scaler does not work with Reaper anymore


first, I know that are some threads about Scaler crashing Reaper. I´ve read them all, but they didn´t help in fixing my Problem.

So… I dowloaded Scaler 2.2 a week ago, installed it and it worked fine. But today while trying to detect some midi notes in my Project, Reaper just crashed.

I opened it up again, same problem, reaper crashes. I tried everything but i can´t get it to work. I tried the VST3, VST3i and also the VST2 Versions. I tried loading Scaler in a new Project but that also didn´t help. I also reinstalled it.

The Thing is, as soon as I load the Plugin, reaper just shuts itself down, no error messages… Sometimes Scaler loads but as soon as I move my Mouse Reaper just crashes.

My System: i7, 16GB RAM, Focusrite Saffire 6 USB2.0, Win10 Home, Reaper 6.18, Scaler 2.2

If there is Anything i can do to help figuring out the Problem let me know (like a Crashreport).

Ok, so fiddled around with some settings. After changing the sample rate to 48khz it just worked fine. I don´t know why because when I first used Scaler last week it was at 96 khz, it is my standard sample rate so…

Hi Denny

another thing to remember (but I suspect you know it already :grinning:) is that sample rate and bit depth of all audio devices in your PC must be identical to the sample rate selected in the ASIO GUI…

and, possibly, all audio devices not in use must be disabled in your OS

my 2 cents (likely useless)